0

Ubuntu 16.04, three 24 inch Acer monitors, AMD FX-8320E CPU, Gigabyte 970A-UD3P board...

Having a heck of a time getting my three monitors working on Ubuntu 16.04. I've tried several cards (Nvidia, Radeon, etc, but most basic graphics cards with DVI/VGA/HDMI can only run dual monitors), and I settled on the 5450 with a special adapter that came with the card (-> 3x DVI). When I bought this card, the reviews were good, and one even described getting it running with three monitors on Ubuntu!

So I got the card, installed it, and I've been fiddling with it for several days now. I'm reading that this card should be supported with the Radeon open source drivers pre-instralled on Ubuntu 16.04:

$ lspci -nn | grep -E 'VGA|Display'

04:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. 
[AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] [1002:68f9]

https://help.ubuntu.com/community/RadeonDriver

After first booting the machine when the new card was installed (no additional Radeon drivers installed), the system would boot but the login screens would lock up. At this point, it did have Nvidia drivers installed, as the previous stable card was a GeForce something or other.

After installing AMDPro, and reinstalling all the AMD Radeon drivers I could find, now the system boots and VT 7 shows the message:

/dev/sda4: clean, xxxxxx/xxxxxxxx files, xxxxxxx/xxxxxxxx blocks

I can switch to a different VT (Ctrl+Alt+F1) and log in, but can't seem to get the graphics to work.

I've tried removing the proprietary fglrx driver, and about whatever I could find to no avail... Any help is much appreciated. Hopefully I can find someone out there with my setup that has made this work.

0

I dug up a spare disk and went to reinstall Ubuntu 16.04.02. Upon boot, I decided to "try" Ubuntu first... To my surprise (or maybe not), all three monitors worked fine. I went ahead and installed to disk, and everything seems to be fine. I'm not entirely sure why, but I'm willing to chalk it up to my fault. I was trying all sorts of things to get it to work, so I probably caused the problem unintentionally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.