2

I have a USB antenna that I got here on Amazon, and unlike in How do I install a Realtek Wireless-N USB Adapter on my Linux OS laptop it doesn't appear that the driver is in the driver tree. Either that or I haven't figured out how to enable the antenna. I'm using a laptop, which has an integrated Wi-Fi connector, but I wanted a better external one. I'm not exactly sure how this works with the wi-fi button on the laptop. I tried installing the default driver, but the installation fails stating that the kernel version isn't supported (It only works on version 3.14), but my Ubuntu version is 16.04, running the default kernel 4.4.0-79-generic, with the KDE environment. How can I enable the USB antenna?

Edit 0: Output of lsusb:

$ lsusb 
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 004: ID 05c8:036e Cheng Uei Precision Industry Co., Ltd (Foxlink) Webcam
Bus 002 Device 015: ID 04f9:0278 Brother Industries, Ltd 
Bus 002 Device 014: ID 1a40:0101 Terminus Technology Inc. Hub
Bus 002 Device 013: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 002 Device 012: ID 0bda:a811 Realtek Semiconductor Corp. 
Bus 002 Device 011: ID 1a40:0201 Terminus Technology Inc. FE 2.1 7-port Hub
Bus 002 Device 010: ID 0c45:7b05 Microdia 
Bus 002 Device 006: ID 138a:0050 Validity Sensors, Inc. Swipe Fingerprint Sensor
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Edit 1: After multiple executions of lsusb with the antenna in and out of the hub I can confirm that Bus 002 Device 012: ID 0bda:a811 Realtek Semiconductor Corp is the device.

Edit 2: According to Someone in the Amazon Questions, the chipset used is Realtek RTL8811AU Wireless LAN 802.11ac USB 2.0 Network Adapter

Edit 3: Output of ifconfig

$ ifconfig
eno1      Link encap:Ethernet  HWaddr a0:1d:48:fa:67:c0  
          inet addr:192.168.1.19  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::fddf:8e79:2441:c273/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1035634 errors:0 dropped:0 overruns:0 frame:0
          TX packets:454085 errors:0 dropped:1 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1479578464 (1.4 GB)  TX bytes:48852719 (48.8 MB)
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:10250 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10250 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:927499 (927.4 KB)  TX bytes:927499 (927.4 KB)

Edit 4: System Settings Network Tab Network Tab

Edit 5:

# lspci -nnk | grep 0280 -A3
07:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter [10ec:8179] (rev 01)
        DeviceName: Realtek RTL8188EE 802.11bgn Wi-Fi Adapter
        Subsystem: Hewlett-Packard Company RTL8188EE Wireless Network Adapter [103c:197d]
        Kernel driver in use: rtl8188ee
  • 1
    Please plug it in and then run the following command and then please post the output, thanks: lsusb – mchid Jun 8 '17 at 2:23
8

With a working internet connection by ethernet, tethered or whatever means possible, open a terminal and do:

sudo apt-get update
sudo apt-get install rtl8812au-dkms

Reboot.

We will also need to blacklist your internal device. First, let's identify it:

lspci -nnk | grep 0280 -A3

To blacklist the driver for the internal device, open the terminal and do:

sudo -i
echo "blacklist rtl8188ee"  >>  /etc/modprobe.d/blacklist.conf
modprobe -r rtl8188ee
exit

You should be all set.

| improve this answer | |
  • Hmm, the internal card was disabled, but the new one is still offline. It doesn't appear in the System Settings -> Connections list either. I verified that the USB antenna works by using it on a windows system, so at least I know it's not dead. – Sarah Szabo Jul 4 '17 at 0:28
  • Is the driver loaded? lsmod | grep 8812 Is it hard blocked? rfkill list all – chili555 Jul 4 '17 at 1:40
  • First command gave no output. Second one gave this: 0: hci0: Bluetooth Soft blocked: no Hard blocked: no – Sarah Szabo Jul 4 '17 at 4:30
  • Please include the rfkill listing and a reference to this question and start a new question as you have what appears to be a new problem. I'll be glad to help. – chili555 Jul 4 '17 at 11:37
  • What do you think I should put as the title of the new question then? It would seem to be a duplicate in my mind. – Sarah Szabo Jul 5 '17 at 2:41
0

Bought this Honey USB 600 Mbps WiFi antenna off Amazon for less than $10 since it claimed it works with Linux. It does, but not plug and play like some of the other more popular adapters. I tried the above methods for Linux (Ubuntu 18.04.2 Bionic Beaver) and they failed; however, they did help me get to this point. I did find a method that works. Just follow the directions (4 steps) on the image in this link ----> Realtek 8812 Honey USB wireless adapter then, Reboot.

If this helps you like it did me, give it a thumbs up!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.