I recently got a new system with an Intel Optane drive. I'm dual booting Ubuntu (I need Linux for some work things, but much of the time I still use Windows).

I had to disable Intel RST in my BIOS to install Ubuntu, and everything is working fine, however when I have tried to re-enable RST in the BIOS Ubuntu will not boot (Windows of course boots fine).

Is there I way I can have Intel RST (and the Optane memory) running in Windows and still be able to boot into Ubuntu? I realize that Ubuntu cannot use these features but I would like to still be able to use them when I boot into Windows.

Edit: So, Ubuntu doesn't have any problems with RST by itself. The problem arrises when I enable the "Optane Mode", after which Ubuntu will not boot (see error messages here). When I boot from a USB none of the hard drives show up.

Edit 2 - Screen shot of errors during boot

Here are two screens of error messages reported during grub boot:



  • Can you take a picture of the grub boot screen with error messages? Jun 7, 2017 at 19:41
  • There are no errors, when I try to boot it just hangs at a black screen.
    – wing-it
    Jun 7, 2017 at 19:42
  • Are the "quiet splash" parameters removed in /boot/grub/grub.cfg file? Jun 7, 2017 at 19:44
  • I have not edited that file, what do I need to do? I assume just change "linux /boot/vmlinuz-4.8.0-54-generic.efi.signed root=UUID=be6c3ede-e72e-4f53-a058-82839ba3ceff ro quiet splash $vt_handoff" to "linux /boot/vmlinuz-4.8.0-54-generic.efi.signed root=UUID=be6c3ede-e72e-4f53-a058-82839ba3ceff ro $vt_handoff" ?
    – wing-it
    Jun 7, 2017 at 19:48
  • If someone doesn't write an answer I will when I'm on my computer. Jun 7, 2017 at 19:52

1 Answer 1


Fallacy: You can't accelerate Windows & Ubuntu concurrently

You can use use Intel RST to accelerate a Windows drive to SSD (usually PCIe mSata on a laptop) and Enhance IO to accelerate Linux (Ubuntu) concurrently, but not simultaneously of course.

There are caveats such as whenever you need to update grub (install a new kernel, update initramfs for some drivers, etc). You need to decelerate the SSD in Windows (with Intel RST software) or BIOS by pressing Ctrl+I during POST (Power On Self Test).

Finding error messages during Ubuntu Boot

By default error messages are hidden for most users during grub boot and a "purple splash screen appears" during the second half of grub boot. To remedy this use:

gksu gedit /etc/default/grub

Look for the line containing:


There may be other options on this line which you should not touch. Remove the options "quiet splash" in order to see error messages during boot up. Leave the double quotes (") at the beginning and ending of the parameter list.

Save the file, exit and then type:

sudo update-grub

NOTE: When using Intel RST you must first decelerate the Windows drive before typing update-grub or update-initramfs when grub is installed on the same drive as the accelerated Windows.


I'll update this answer as new information is provided by the OP. Coincidentally it was disk acceleration under Ubuntu 14.04 that brought me to Ask Ubuntu in the first place. You can search my very first couple of posts here for information on using Enhance IO to accelerate Ubuntu.

  • Here is what I got when I updated the grub and enabled "Optane mode" in my BIOS.
    – wing-it
    Jun 8, 2017 at 11:57
  • Check the answer in this similar question: askubuntu.com/questions/822828/… Jun 9, 2017 at 0:46
  • I followed that answer as best as I could, "root=UUID=[numbers]" was already in included. i added the vgchange command (not in the grub.cfg, I pressed 'e' to edit the command once before booting). I got the same error as before.
    – wing-it
    Jun 9, 2017 at 11:32
  • You might want to google the error message and read all the links Jun 9, 2017 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.