I'm new to Ubuntu, so please be gentle.

I tried to update the OS through the software centre, but got an internal error. I restarted and then tried to update again. Nothing will update or be removed. There's an error message saying Error: BrokenCount > 0.

I've searched for this on this site, and followed the instruction of the top answer: gksu software-properties-gtk. However, I don't have the program installed that is needed. When I try to install it with sudo apt install gksu I get errors about unmet dependencies. When I follow the advice to type apt-get -f install I get messages about permission being denied and asking if I'm the root. (I've included a picture of the terminal)

The common theme - from my own computer and other posts on here - is that it's problems with third party repositories. I only installed Ubuntu 16.04 LTS last night. The only program I installed was PlayOnLinux.

Like I said - I'm a total noob. All the commands above I got from the internet. I have no idea how to do anything.

enter image description here

  • Use sudo -H instead of gksu in your first command. For the last one, use sudo apt install -f
    – Zanna
    Jun 7, 2017 at 16:35
  • @Zanna Thank you very much for helping a lost soul. Jun 7, 2017 at 16:48
  • Did you manage? :) if you fixed it, could you perhaps write an answer explaining how? If not, please edit your question so we know what is still not working
    – Zanna
    Jun 7, 2017 at 16:56
  • @Zanna It worked perfectly. Thank you! I have written an answer as you suggested. Best wishes. Jun 7, 2017 at 17:20

1 Answer 1


As Zanna suggested, I used

sudo -H software-properties-gtk

instead of

gksu software-properties-gtk

When I did that, it opened the window shown in the top answer of the post I linked to. I then followed their instructions:

  • I went to "other software" tab,
  • Selected and removed all of the third party repositories,
  • sudo apt-get update && sudo apt-get install -f && sudo apt-get update,
  • Losts of code scrolled through the terminal window,
  • I restarted my machine - not sure if necessary,
  • I went back to the Ubuntu Software and clicked install - they installed.

All updates were then successful.

  • You can also accept your own answer, that way people scrolling through search results will see that the issue has been resolved.
    – Robby1212
    Jun 7, 2017 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.