0

I was running 16.04.2 LTS today(2017/June/07) and did system update (reboot required) when I brought up the system the wired network was not working .

To get around this issue, I rebooted again in GRUB went to advanced, selected the previous *-generic kernel vmlinuz-4.4.0.78-generic.

I rebooted and networking is now working, before reboot went into "Network" system setting and noticed that there were no lines for "Wired".

This is my work PC so problem analysis will need to wait until later today (assuming I have the chance) to do some reboots but initially looks like some type of NetManager update issue losing previous information and not auto detecting the network ...

Here are the relevant log entries:

NOTE 
george@njcvr25:/var/log/apt$ pwd
/var/log/apt
george@njcvr25:/var/log/apt$ more history.log

Start-Date: 2017-06-02  17:09:53
Commandline: aptdaemon role='role-commit-packages' sender=':1.311'
Upgrade: libldap-2.4-2:amd64 (2.4.42+dfsg-2ubuntu3.1, 2.4.42+dfsg-2ubuntu3.2), libsndfile1:amd64 (1.0.25-10, 1.0.25-10ubuntu0.16.0
4.1)
End-Date: 2017-06-02  17:09:56

Start-Date: 2017-06-02  17:10:03
Commandline: aptdaemon role='role-commit-packages' sender=':1.311'
Upgrade: isc-dhcp-common:amd64 (4.3.3-5ubuntu12.6, 4.3.3-5ubuntu12.7), isc-dhcp-client:amd64 (4.3.3-5ubuntu12.6, 4.3.3-5ubuntu12.7
)
End-Date: 2017-06-02  17:10:07

Start-Date: 2017-06-06  07:51:02
Commandline: aptdaemon role='role-commit-packages' sender=':1.174'
Upgrade: libtasn1-6:amd64 (4.7-3ubuntu0.16.04.1, 4.7-3ubuntu0.16.04.2)
End-Date: 2017-06-06  07:51:04

Start-Date: 2017-06-07  11:32:25
Commandline: aptdaemon role='role-commit-packages' sender=':1.310'
Install: linux-signed-image-4.4.0-79-generic:amd64 (4.4.0-79.100, automatic), linux-image-4.4.0-79-generic:amd64 (4.4.0-79.100, au
tomatic), linux-image-extra-4.4.0-79-generic:amd64 (4.4.0-79.100, automatic), linux-headers-4.4.0-79:amd64 (4.4.0-79.100, automati
c), linux-headers-4.4.0-79-generic:amd64 (4.4.0-79.100, automatic)
Upgrade: libnl-route-3-200:amd64 (3.2.27-1, 3.2.27-1ubuntu0.16.04.1), linux-headers-generic:amd64 (4.4.0.78.84, 4.4.0.79.85), linu
x-libc-dev:amd64 (4.4.0-78.99, 4.4.0-79.100), libnl-genl-3-200:amd64 (3.2.27-1, 3.2.27-1ubuntu0.16.04.1), linux-image-generic:amd6
4 (4.4.0.78.84, 4.4.0.79.85), linux-signed-image-generic:amd64 (4.4.0.78.84, 4.4.0.79.85), linux-signed-generic:amd64 (4.4.0.78.84
, 4.4.0.79.85), libnl-3-200:amd64 (3.2.27-1, 3.2.27-1ubuntu0.16.04.1), lintian:amd64 (2.5.43, 2.5.43ubuntu0.1), linux-generic:amd6
4 (4.4.0.78.84, 4.4.0.79.85)
End-Date: 2017-06-07  11:33:49
george@njcvr25:/var/log/apt$ 
6
  • latest apt history log follows ... Jun 7, 2017 at 16:22
  • I also received an update yesterday that forced me to restart, after restarting my network connection wasn't working. I simply disable networking and re-enabled it and everything worked after that. I did have an entry for wired network, so my problem might not be similar to yours. Just wanted to say that whatever that update was, it did mess with networking in some level
    – Felipe
    Jun 7, 2017 at 18:14
  • rebooted again with the same issue ... however this time when i went back to the older kernel networking was not working with that either ... seems to be a NetworkManager issue ... Next what I did was change /etc/network/interfaces to explicitly define my network ... Jun 7, 2017 at 22:18
  • Filipe ... sounds like a good idea ... will try that next tomorrow when i come to work ... today leaving for the day ... BTW ... my idea with the above change to interfaces ... i remembered something like this happening about a year ago and that was what i did to get networking working again ... did not think of stop and start of the network process Jun 7, 2017 at 22:23
  • I still have an issue with networking ... it seems to be isolated with NetworkManager ... I have a network connection by manually editing /etc/network/interfaces ... but whenever i try to get connection information from network manager(GUI) ... it replies with "error displaying connection information: No valid active connections found!" Jun 8, 2017 at 18:31

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.