3

I have gone through the existing answers, and none of them work for me.

I am using Ubuntu Gnome 16.04. In Ubuntu, Kubuntu, and even Xubuntu, there is an entry in Settings->Mouse to "disable touchpad while typing".

I have looked in Settings, Gnome tweak tool, and dconf-editor. None of them have any such option.

Here is the output of xinput:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
↳ Power Button                              id=6    [slave  keyboard (3)]
↳ Video Bus                                 id=7    [slave  keyboard (3)]
↳ Power Button                              id=8    [slave  keyboard (3)]
↳ Video Bus                                 id=9    [slave  keyboard (3)]
↳ Laptop_Integrated_Webcam_HD               id=10   [slave  keyboard (3)]
↳ AT Translated Set 2 keyboard              id=11   [slave  keyboard (3)]
↳ Dell WMI hotkeys                          id=13   [slave  keyboard (3)]

Please help me in solving this.

  • It looks like libinput is used. It does not have GUI settings. But the feature is enabled by default. – Pilot6 Jun 7 '17 at 13:47
  • @jhilmer This will work only for xorg-synaptics, not in libinput. – Pilot6 Jun 7 '17 at 13:49
  • @jhilmer That is about Macbook, while mine is about Ubuntu Gnome. – enitihas Jun 7 '17 at 13:51
  • Please edit your question and add output of xinput terminal command. – Pilot6 Jun 7 '17 at 14:26
  • The command is gsettings set org.gnome.desktop.peripherals.touchpad send-events disabled, or better; use syndaemon askubuntu.com/a/743259/72216 on 16.04 and up. – Jacob Vlijm Jun 7 '17 at 15:15
5

Using your terminal, enter

gsettings get org.gnome.desktop.peripherals.touchpad disable-while-typing

This will show you true, if the system is set to disable the touchpad while typing. You can set the key with

gsettings set org.gnome.desktop.peripherals.touchpad disable-while-typing true

Graphically, run dconf_editor, and navigate to the path org->gnome->->desktop->peripherals->touchpad and inspect the value of the key disable-while-typing

| improve this answer | |
  • Running 'gsettings get org.gnome.desktop.peripherals.touchpad disable-while-typing' gives the output No such key 'disable-while-typing' Also, there is no 'disable-while-typing' option in dconf in the path you specified. – enitihas Jun 7 '17 at 14:41
  • Weird - it's present in 17.04, perhaps an upgrade from 16.04? Gsettings and dconf both fo to the same data set, they are CLI and GUI programs for getting to the settings. I assume that you do not want to disable the touchpad entirely... – Charles Green Jun 8 '17 at 4:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.