5

Today I upgraded my Ubuntu distro from 16.04 to 17.04. Result: the keyboard and the usb ports don't work anymore.

I upgraded the distro via command line:

sudo apt update && sudo apt dist-upgrade
sudo do-release-upgrade

It seems that I need to install a generic linux kernel.

Problem: if I run the installed version of Ubuntu I cannot install the kernel.

Can I install a kernel on my system from a live session?

  • 1
    How did you upgrade? What was 16 and what is "the latest"? – Pilot6 Jun 7 '17 at 9:33
  • @Pilot6 post edited – Salvatore Di Fazio Jun 7 '17 at 9:40
  • It is not clear which version did you upgrade to which. Maybe upgrade was interrupted too. – Pilot6 Jun 7 '17 at 9:42
  • @Pilot6 what is the deal with the versions? Anyway from 16.04 Lts to 17.04 (I thought this is the latest one) – Salvatore Di Fazio Jun 7 '17 at 9:50
  • There's no supported direct upgrade path from Ubuntu 16.04 to 17.04. – David Foerster Jun 14 '17 at 15:28
3

I solved the issue following these steps on the Ubuntu help wiki

Update Failure

If there was an update that made your system non-bootable and they have fixed it in the repositories, you can use the Live CD to run apt-get to get the new files to fix your system.

Boot the Ubuntu Live CD. Press Ctrl-Alt-F1

sudo mount /dev/sda1 /mnt
sudo mount --bind /dev /mnt/dev
sudo mount --bind /proc /mnt/proc
sudo mount --bind /sys /mnt/sys
sudo chroot /mnt
sudo apt update
sudo apt upgrade

Then

sudo apt dist-upgrade -y && sudo apt install -y ubuntu-desktop*
3

I had a similar problem, upgraded from 16.04 to 17.o4 and found my keyboard no longer worked.

Found the fix here:

https://askubuntu.com/a/932041

1

I also had this issue after the upgrade. After reading several posts, it seems that the issue is related to a missing package.

1st Start Ubuntu in recovery mode

2nd Select the Enable Networking option in the menu

3rd Now, select the root option and enter your root password (if set)

4th Configure your DNS In the command line edit the file: /etc/resolv.conf example: pico /etc/resolv.conf or vi /etc/resolv.conf Add to the first line of the file.

nameserver 208.67.222.222

Now save the file

5th install the missing package

apt install xserver-xorg-input-all

Finally restart your machine and your are good to go!

  • 1
    Welcome to Ask Ubuntu! In its current form your answer is not as good as it could be. Could you review How to Write a Good Answer, and Style guide for questions and answers. Specifically the markdown editor supports numbered lists. Also Could you clarify why changing the dns would be needed? – J. Starnes Jan 13 '18 at 3:31
  • Did help me - /etc/resolv.conf was not there and subsequently the apt install didn‘t work. Thanks. – dr. rAI Jun 22 '18 at 4:56
0

I had this issue. Luckily I was able to re-install 16.04 LTS and re-update to 17.04 on an old test laptop (HP EliteBook 8530p).

At the end of the update when it asks to remove obsolete packages, I simply chose KEEP and my mouse and keyboard worked after reboot.

Unfortunately, this solution only works if you find this answer before you dismiss that dialog and reboot. Otherwise, other solutions are required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.