0

I need some help with installation of firefox older version. Also I have to make it work with SlimerJS npm module. As it says on SlimerJS website it works with versions of firefox from 38.0 to 52.0. So, this is my steps:

  1. Download an archive from mozilla cdn

    wget -c https://download-installer.cdn.mozilla.net/pub/firefox/releases/51.0b9/linux-x86_64/en-US/firefox-51.0b9.tar.bz2`
    
  2. Extract this archive

    tar xjf firefox-51.0b9.tar.bz2
    
  3. Configure SlimerJS as the docs say

    export SLIMERJSLAUNCHER=/usr/bin/firefox
    
  4. Run my testing script (just simple console.log("Hello Slimer!");)

    slimerjs test-1.js --debug=true
    

As a result I have this in my terminal:

Error: GDK_BACKEND does not match available displays
Gecko error: it seems /usr/bin/firefox is not compatible with SlimerJS.
See Gecko version compatibility. If version is correct, launch slimerjs
with --debug=true to see Firefox error message

May be I'm doing something wrong? Please help me If someone has an idea. I really want to make this stuff working.

2

The best solution for same this error :

Error: Platform version '5x.xx' is not compatible with or Gecko error: it seems /usr/bin/firefox is not compatible with SlimerJS.
See Gecko version compatibility. If version is correct, launch slimerjs
with --debug=true to see Firefox error message

is use old firefox version inside your updated firefox:

  1. update SlimerJS and make sure this the latest version.

  2. Download the mozilla firefox version 50 from : https://ftp.mozilla.org/pub/firefox/releases/50.0/ and choose your OS and i386 or x64 and favorite lang for example i download https://ftp.mozilla.org/pub/firefox/releases/50.0/linux-x86_64/en-US/firefox-50.0.tar.bz2 for Ubuntu 16.04 64bit

  3. then extract the downloaded file:

    $ tar xvjf firefox-50.0.tar.bz2

for example i extract into /home/username/oldmozilla

  1. set extracted directory to SLIMERJSLAUNCHER path:

    $ export SLIMERJSLAUNCHER=/home/yourname/oldmozilla/firefox/firefox

note: you must give firefox app not directory

  1. run your js app simply ; )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.