1

I have a problem: For some reason, if I open a file from inside an application (such as in Firefox "Open downloaded file in folder", for example), it only opens gnome-terminal in the home directory, which isn't useful at all.

This was probably caused because I tried setting the default file browser to Dolphin instead of Nautilus. However, I don't remember what I did exactly.

I've tried looking into /usr/share/applications/mimeinfo.cache:

inode/directory=
org.gnome.Nautilus.desktop;
org.gnome.baobab.desktop;
org.kde.dolphin.desktop;
org.kde.gwenview.desktop;
nemo.desktop;easytag.desktop;
git-cola-folder-handler.desktop;
kde4-kfmclient_dir.desktop;

Everything seems normal (line breaks are only for easier reading, this is all in one line). Then I tried sudo update-mime-database /usr/share/mime and rebooting - nothing. If I try to open a file in the file browser, all I get is a terminal in the home directory.

How do I reset this to the default file browser or any file browser?

  • Check your ~/.local/share/applications/mimeapps.list – user128285 Jun 7 '17 at 9:59
  • Hm, it says inode/directory=kde4-dolphin.desktop. Maybe missing an org.? Not sure. – BiggCrazy Jun 7 '17 at 12:30
  • Not sure as well but you can give it a try. – user128285 Jun 7 '17 at 13:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.