This is kinda strange.

The router is set fine and I can see it from a Mac and from 2 mobile phones. Is WEP protected and not hidden or other tricks, as it comes from the box. My Ubuntu is 10.04 on HP Pavillion DV1000.

When I try to connect from Ubuntu, it does see other networks (10 or more) but not my own. I've tried restarts, ifconfig up/down, rfkill block/unblock wifi, installing b43-fwcutter and nothing works.

I would appreciate any suggestions. Thanks

$ sudo lshw -C network
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 02
       serial: 00:19:d2:0c:a6:bf
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:27 memory:d6000000-d6000fff
       description: Ethernet interface
       product: PRO/100 VE Network Connection
       vendor: Intel Corporation
       physical id: 8
       bus info: pci@0000:05:08.0
       logical name: eth0
       version: 02
       serial: 00:16:36:4e:9b:60
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=full firmware=N/A ip= latency=64 link=yes maxlatency=56 mingnt=8 multicast=yes port=MII speed=100MB/s
       resources: irq:20 memory:d8000000-d8000fff ioport:4000(size=64)

 $ sudo iwlist scan
 lo        Interface doesn't support scanning.

 eth0      Interface doesn't support scanning.

 wlan0     Scan completed :
           Cell 01 - Address: 00:21:29:C7:5C:82
                Frequency:2.437 GHz (Channel 6)
                Quality=39/70  Signal level=-71 dBm  
                Encryption key:on
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                          24 Mb/s; 36 Mb/s; 54 Mb/s
                Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                Extra: Last beacon: 1588ms ago
                IE: Unknown: 000C416C7665766569656E323237
                IE: Unknown: 010882848B962430486C
                IE: Unknown: 030106
                IE: Unknown: 2A0100
                IE: Unknown: 2F0100
                IE: Unknown: 32040C121860
                IE: Unknown: 2D1A0C181AFFFF000000000000000000000000000000000000000000
                IE: Unknown: 3D1606001300000000000000000000000000000000000000
                IE: Unknown: DD930050F204104A00011010440001021041000100103B00010310470010109070C00000109070C0004000000000102100244C696E6B7379732C2041204469766973696F6E206F6620436973636F2053797374656D73102300075752543631304E1024000876312E30302E30301042000234321054000800060050F2040001101100075752543631304E100800020088103C000103
                IE: Unknown: DD090010180202F0050000
                IE: WPA Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (1) : TKIP
                    Authentication Suites (1) : PSK
                IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                IE: Unknown: DD1E00904C330C181AFFFF000000000000000000000000000000000000000000
                IE: Unknown: DD1A00904C3406001300000000000000000000000000000000000000
      Cell 02 - Address: 34:21:09:02:FF:A0
                Frequency:2.452 GHz (Channel 9)
                Quality=22/70  Signal level=-88 dBm  
                Encryption key:on
                ESSID:"Kontoret 2"
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                          18 Mb/s; 36 Mb/s; 54 Mb/s
                Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                Extra: Last beacon: 1496ms ago
                IE: Unknown: 000A4B6F6E746F7265742032
                IE: Unknown: 010882848B961224486C
                IE: Unknown: 030109
                IE: Unknown: 32040C183060
                IE: Unknown: 33082001020304050607
                IE: Unknown: 33082105060708090A0B
                IE: Unknown: DD270050F204104A0001101044000102104700102880288028801880A88034210902FFA0103C000101
                IE: Unknown: 050400030080
                IE: Unknown: 2A0104
                IE: Unknown: 2D1AEE1117FFFF0000010000000000000000000000000C0000000000
                IE: Unknown: 3D1609070700000000000000000000000000000000000000
                IE: Unknown: 7F0101
                IE: WPA Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (2) : TKIP CCMP
                    Authentication Suites (1) : PSK
                IE: IEEE 802.11i/WPA2 Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (2) : TKIP CCMP
                    Authentication Suites (1) : PSK
                IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                IE: Unknown: 0B0505002D127A
                IE: Unknown: DD1E00904C33EE1117FFFF0000010000000000000000000000000C0000000000
                IE: Unknown: DD1A00904C3409070700000000000000000000000000000000000000
                IE: Unknown: DD07000C4304000000

To see available wifi networks you probably want to do:

sudo iwlist scan

By lshw -C network you have listed network interfaces and their current configuration.

  • I've updated the results. I see only two of the 10 networks that I see normally. The second one has the mode Mode:Unknown/bug. Is this strange? can it block my wifi scanner somehow? – Elzo Valugi Jan 2 '12 at 19:27
  • if you run sudo iwlist scan several times you may get more results – Michał Šrajer Jan 2 '12 at 19:43
  • the results seem truncated... how do I tell the interface to scan until it gets mine, which is the strongest one by the way? – Elzo Valugi Jan 2 '12 at 19:50
  • +1 thanks for the suggestion of using iwlist. the fix was close – Elzo Valugi Jan 2 '12 at 21:10

The fix. It seems that this wifi booard does not support the channel 13 which was automatically given by my router. Forcing it to a supported channel (10) solved the issue.

$ sudo iwlist channel 
    wlan0     24 channels in total; available frequencies :
      Channel 01 : 2.412 GHz
      Channel 02 : 2.417 GHz
      Channel 03 : 2.422 GHz
      Channel 04 : 2.427 GHz
      Channel 05 : 2.432 GHz
      Channel 06 : 2.437 GHz
      Channel 07 : 2.442 GHz
      Channel 08 : 2.447 GHz
      Channel 09 : 2.452 GHz
      Channel 10 : 2.457 GHz
      Channel 11 : 2.462 GHz
      Channel 36 : 5.18 GHz
      Channel 40 : 5.2 GHz
      Channel 44 : 5.22 GHz
      Channel 48 : 5.24 GHz
      Channel 52 : 5.26 GHz
      Channel 56 : 5.28 GHz
      Channel 60 : 5.3 GHz
      Channel 64 : 5.32 GHz
      Channel 149 : 5.745 GHz
      Channel 153 : 5.765 GHz
      Channel 157 : 5.785 GHz
      Channel 161 : 5.805 GHz
      Channel 165 : 5.825 GHz
      Current Frequency=2.457 GHz (Channel 10)

Mistery solved. No black magic, just lack of knowledge on my part. Thanks everybody.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.