After 2 - 4 hours my laptops starts showing me a black screen when I click somewhere. This has happened many times, and it happens only when my laptop is awake for a long time and a lots of tabs are open. (Firefox and multiple terminals in diverse workspaces) I do suspend it for 5 or 10 minutes by closing its lid. This problem happens more when multiple terminals are open. Also fans of the laptop makes so much loud

Machine info:

  • Acer Aspire 5742

  • Intel Core i3-370M

  • 4 GB ram

  • Intel HD graphics

  • Triple boot (Ubuntu Mate 16.04, CentOS 7, Windows 7)

The time has reduced to one-half to one hour. It is getting worse, I can't do any work. Is it a hardware or software problem?

I posted it here too.

Also now it is getting worst and it shows me black screen after 15 or 20 minutes.I have found so many logs in /var/log which mentions time when black screen shows off,but they are too many i didn't understand them.I don't think that it my screen problem as when black screen shows off,The song in my headphone Also stops playing!!

edit 22 July

I am using Linux mint XFCE 18.2(which is in other words is Xubutnu) and I am not getting this problem.I am using Linux mint XFCE. since one month.Also I was not getting this problem in Ubuntu unity.Thus I think that this is not my hardware problem but is related to Ubuntu mate.

  • Can you find any related information in the logs in /var/log?
    – Melebius
    Jun 12, 2017 at 7:23
  • @Melebius thanks for reply,but please tell me what are these logs? some people on ubutnu-mate-comutiny had also asked the same.but i am noob in Linux
    – user690429
    Jun 12, 2017 at 7:25
  • See askubuntu.com/questions/26237/…, for example.
    – Melebius
    Jun 12, 2017 at 7:36
  • i will provide logs when it will happen again
    – user690429
    Jun 14, 2017 at 15:30
  • 1
    Disable lockscreen, set all the Display power management settings to Never (I'm on Xubuntu so things may be called differently). Then see if the problem returns.
    – user595510
    Jun 27, 2017 at 11:42

2 Answers 2


I'd suspect an overheating issue, especially if it is getting worse over time. Your comment that the fans get loud indicate that either the bearings are wearing out or that they are PWM fans and are reacting to the high internal heat by speeding up. This does not sound like a kernel version or a RAM issue to me although high heat can certainly adversely effect performance and stability.

More windows open means more work for the CPU and perhaps GPU to do. And thus, more heat generated.

Could be a clogged filter, clogged air inlet, a dead fan and so on. Or that you are just running more processes than your laptop is capable of handling.

A quick test to validate this theory would be to take the laptop some place cool, such as outside.

Overheating to the point of shutting down every 2-4 hours will make it difficult to test for improvements. Failing every 30 minutes, not so difficult.

When in a suspended state, the inside of the laptop case will eventually cool down because not much will be running.

You can install psensor which will monitor temps and discovered fans. Alerts can be displayed based on thresholds that you specify. There are several very good threads on this site explaining how to do this.


  • how can i install psensor??
    – user690429
    Jun 22, 2017 at 16:52
  • I don't think that it is overheating problem as its winter here and my laptops shows me black screen again when I just opened it,It pretty cool at that time.
    – user690429
    Jun 26, 2017 at 7:50
  • "how can i install psensor??"... sudo apt-get update and sudo apt-get psensor will do the needful.
    – DK Bose
    Jul 1, 2017 at 17:13

Start by installing newer kernel and Xorg versions:

sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

After that, try installing the latest Mesa version:

sudo add-apt-repository ppa:paulo-miguel-dias/pkppa
sudo apt update
sudo apt upgrade

If you still have issues, it is probably a hardware problem (Acers=ugh. In the future, by a Dell or Toshiba) Try using Memtest86+ (one of the options in the Grub screen) and let the test run for a few hours.

  • I installed new kernel,and problem was not occurring until last 5 days,but now suddenly it is showing up again!!!! the new kernel is 4.10.0-22-generic
    – user690429
    Jun 22, 2017 at 16:49
  • Have you tried Memtest86+ yet? Jun 22, 2017 at 18:52
  • No.I don't even know what is it?Can you please tell me what it is and how can i try it out?
    – user690429
    Jun 23, 2017 at 3:56
  • i ran memtest86+ and no errors were found.
    – user690429
    Jun 24, 2017 at 1:00

You must log in to answer this question.