I tried installing IDLE in two ways, using Ubuntu Software Center and using terminal.

But neither way allows me to install idle.

  1. In Ubuntu Software Center, many popular and essential applications do not show up for me (like IDLE, Adobe flash player,etc)

  2. When I tried installing using terminal, it said

    E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
    E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

2 Answers 2


It says that the lock file which indicates a dpkg process is running is present. It means either another program is using dpkg (apt, synaptic, auto update, etc.) or there was a problem removing that lock the previous time. The safest way is to reboot your system to reset this lock. If you are sure there is no other process using dpkg, you can also remove that lock manually.

$ sudo rm lock /var/lib/dpkg/lock

Another process using your apt port. close other software installers like ubuntu software manager, synaptic package manager etc then try. if problem persists, you may need to fix your sources.list file.

Not the answer you're looking for? Browse other questions tagged .