10

TL;DR: What is the syntax to mount a CIFS share via SMB3 in /etc/fstab?

Previously, I had this working in my /etc/fstab:

//192.168.1.100/Movies /mnt/Media cifs credentials=/home/syn/.smbcred,uid=111,gid=1000,iocharset=utf8 0 0

But after some bug with the server, I now need to specify the SMB version when mounting. I am able to do this via mount:

sudo mount -t cifs //192.168.1.100/Movies /mnt/Media -o vers=3.0,user=plex,uid=111,gid=1000,pass=PASSWORD

But I cannot seem to specify the version in fstab and get it to work. Any ideas?

Similar thread here, but unanswered.

  • See the samba config file:samba.org/samba/docs/man/manpages-3/smb.conf.5.html SMB3 is the default by the way unless you specify otherwise and it will use a lower version when the client asks for it. – Rinzwind Jun 6 '17 at 12:53
  • If you mount shares from a modern version of Windows, do not use vers=1.0. This version of SMB protocol is deprecated, unefficient and gives you a very bad performance. Use vers=3.0 as minimum and if doesn’t work, specify sec=ntlmv2 It’s another common issue that some people use sec=ntlm instead of sec=ntlmv2. Ntlmv1 is an insecure authentication method and it’s disabled by security updates on Windows or Windows Server which hosts the share. So you probably get a permission/authentication related error when try to mount the share with sec=ntlm Cheers – Dean Sep 9 '18 at 20:14
14

I had the same problem which was also due to an upgrade to one of my institute’s servers. I managed to mount the share by adding the vers=3.0 option to fstab without the -o argument.

sudo mount -t cifs //192.168.1.100/Movies /mnt/Media vers=3.0,user=plex,uid=111,gid=1000,pass=PASSWORD
| improve this answer | |
  • 1
    While this post was a while ago and I had figured out the syntax, I forgot to update the post. Thank you, kmdouglass, for posting. Here is my working syntax for mounting a CIFS 3 hosted on FreeNAS to Ubuntu: //192.168.1.1/Media /mnt/Media cifs credentials=/home/me/.smbcred,uid=100,gid=1000,vers=3.0,iocharset=utf8 0 0 Edit based on your local environment. -o is not needed in /etc/fstab – synthetiq Oct 12 '17 at 10:59
0

I ran into the same issue after installing Ubuntu 18.04. Package cifs-utils now uses SMB 2.1 or greater and I needed to use version 1.

In /etc/fstab add vers=n.n right after your credentials file like here:

//192.168.1.144/video /media/nas/ cifs auto,credentials=/.smbcredentials_3,vers=1.0,iocharset=utf8,sec=ntlm 0 0
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.