1

So I have just installed Xubuntu 16.04 and everything was running great until one day I realized my sound control on my keyboard wasnt working. Also, I could not control my audio using the sound indicator in the task bar. I could see a blank icon. When I clicked it I get the sound menu but clicking "Sound Settings..." gets me a window that says:

Connection to Pulse Audio failed. Automatic retry in 5s In this case
this is likely because PULSE_SERVER in the Environment/X11 Root Window
Properties or default-server in client.conf is misconfigured This
situation can also arise when PulseAudio crashed and left stale
details in the X11 Root Window If this is the case, then PulseAudio
should autospawn again, or if this is not configured you should run
start-pulseaudio-x11 manually

This is what I get to see if the process is running

[4][21:59][~]: ps aux | grep pulse
lightdm   1207  0.1  0.0 335808  9396 ?        S<l  21:50   0:00 /usr/bin/pulseaudio --start --log-target=syslog
tfernan+  3356  0.0  0.0 158236  3548 ?        S    21:59   0:00 /usr/bin/pulseaudio --start --log-target=syslog
tfernan+  3361  0.0  0.0 158236   656 ?        Ss   21:59   0:00 /usr/bin/pulseaudio --start --log-target=syslog
tfernan+  3362  0.0  0.0 313116  8852 ?        D<   21:59   0:00 /usr/bin/pulseaudio --start --log-target=syslog
tfernan+  3364  0.0  0.0  14224   988 pts/3    S+   21:59   0:00 grep --color=auto pulse

I ran the following commands:

sudo killall -9 pulseaudio

pulseaudio --kill

rm ~/.pulse-cookie

sudo apt --purge --reinstall install pulseaudio

I tried recreating my /etc/pulse/default.pa file to the default in case apt didn't already do that.

I tried rerunning pulseaudio:

[21][22:07][~]: pulseaudio 
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.
[22][22:07][~]: pulseaudio -D
E: [pulseaudio] main.c: Daemon startup failed.

I seems the daemon is already running.

I did get some interesting output in running pulseaudio -vv

Here is the line I found interesting:

E: [pulseaudio] module-udev-detect.c: You apparently ran out of inotify watches, probably because Tracker/Beagle took them all away. I wished people would do their homework first and fix inotify before using it for watching whole directory trees which is something the current inotify is certainly not useful for. Please make sure to drop the Tracker/Beagle guys a line complaining about their broken use of inotify.
1

So the answer I found to my problem was this:

I had Ulauncher installed which was likely misusing inotify as the error indicated in the command in my question pulseaudio -vv.

I ran killall -9 ulauncher and almost instantly my pavucontrol window was able to be opened.

I have since removed ulauncher from my system and haven't had any issues.

1
  • 1
    I had fixed this problem however wanted to post incase someone runs into this in the future. Hopefully I am allowed to do that :D Jun 6 '17 at 2:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.