I'm trying to set up my app development environment and have hit a snag. When I connect an Android device to my laptop running Ubuntu 16.04, it is not recognized in any way. It starts charging, but I don't get any popups asking me to connect or mount it. This is happening with two different devices (Samsung Galaxy S8 Plus and Lenovo Yoga Book) and multiple USB cables.

When I run lsusb it does not show any Android devices. I have connected to every USB port on the laptop and none of them are working.

Bus 002 Device 003: ID 0a5c:21e1 Broadcom Corp. HP Portable SoftSailing
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 04f2:b270 Chicony Electronics Co., Ltd 
Bus 001 Device 003: ID 138a:003d Validity Sensors, Inc. VFS491
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I created an Android rules file with the following contents:

SUBSYSTEM=="usb", ATTRS{idVendor}=="0bb4", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0502", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="1004", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="22b8", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="04e8", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0fce", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="0489", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="18d1", SYMLINK+="android_adb", MODE="0666"
SUBSYSTEM=="usb", ATTRS{idVendor}=="04e8", MODE="0666", GROUP="plugdev"dev

I've edited /etc/fuse.conf

# /etc/fuse.conf - Configuration file for Filesystem in Userspace (FUSE)

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#mount_max = 1000

# Allow non-root users to specify the allow_other or allow_root mount options.

I've turned on developer options and enabled USB debugging on both. My user is part of the plugdev user group.

adb devices is empty.

I've already rebooted a few times.

These are all of the steps I have found when searching online. Nothing has resolved the issue so far.

I don't know what the next step is. Does anyone have a suggestion?

Edit to Add

When viewing the system logs, if I connect a different USB device, such as a headset, I see a lot of activity in the system log. When I connect an Android device, nothing happens in the logs. It's like it just doesn't detect anything at all. I don't understand this.

Edit to Add 2

Okay, so I figured out what was wrong and it was really silly. I forgot that I had a charging case on my phone. Apparently you can transfer data through the pass-through port on the charging case. After removing the case, I can connect my Samsung phone. The other two tablets still don't connect, but they use a different USB cable, so maybe there is an issue with that cable. That was really frustrating!

  • Please use the usbs that came with the phones I noticed it will only show up when done this way, – George Udosen Jun 5 '17 at 18:29
  • I'm using the USB cable that came with the phone. – RaneWrites Jun 5 '17 at 18:46
  • If you worked out what your problem was, please consider writing an answer to your own question and accepting it. – Josh Jun 6 '17 at 16:16

Chiming in with somewhat similar experience: The issue was a cable I bought from dx.com. It charged but it wouldn't connect data. Even weirder is that it worked in Windows 10.

A micro-USB with a micro-to-C-adapter worked though! Also bought from China

tl;dr: Try different cables, preferrably the original one (I've lost it)


After wasting about a half a day trying to figure out why this wouldn't work, I realized the problem with my Samsung Galaxy S8 Plus was that I was using a charging case. The pass-though port on the charging case doesn't support data transfer, so I need to remove it when I am connecting to the computer.

As for the other devices, I assume there is an issue with the cable I was using to connect then, but I haven't tested that yet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.