1

I'm getting some RAID erros on system init.

[    9.535614] md: raid0 personality registered for level 0
[   10.359621] md: raid1 personality registered for level 1
[   11.182608] raid6: sse2x1   10038 MB/s
[   11.306484] raid6: sse2x2   12550 MB/s
[   11.430366] raid6: sse2x4   14551 MB/s
[   11.487515] raid6: using algorithm sse2x4 (14551 MB/s)
[   11.545150] raid6: using ssse3x2 recovery algorithm
[   11.815714] md: raid6 personality registered for level 6
[   11.871366] md: raid5 personality registered for level 5
[   11.927485] md: raid4 personality registered for level 4
[   12.040689] md: raid10 personality registered for level 10
[   56.061726] systemd-udevd[826]: conflicting device node '/dev/mapper/isw_cgafjgajjg_raid1' found, link to '/dev/dm-2' will not be created
[   56.711217] systemd-udevd[822]: conflicting device node '/dev/mapper/isw_gbfahdijc_Raid2p1' found, link to '/dev/dm-5' will not be created

I have a INTEL hardware RAID (Supermicro with 82801 SATA Controller [RAID mode]), and this is the RAID info:

------------:/home/jjw# dmsetup ls
isw_cgafjgajjg_raid5    (252:4)
isw_cgafjgajjg_raid2    (252:3)
isw_gbfahdijc_Raid2     (252:0)
isw_cgafjgajjg_raid1    (252:2)
isw_gbfahdijc_Raid2p2   (252:6)
isw_gbfahdijc_Raid2p1   (252:5)
isw_cgafjgajjg_raid     (252:1)
------------:/home/jjw# dmraid -r
/dev/sdd: isw, "isw_gbfahdijc", GROUP, ok, 3907029166 sectors, data@ 0
/dev/sdc: isw, "isw_gbfahdijc", GROUP, ok, 3907029166 sectors, data@ 0
/dev/sdb: isw, "isw_cgafjgajjg", GROUP, ok, 1953525166 sectors, data@ 0
/dev/sda: isw, "isw_cgafjgajjg", GROUP, ok, 1953525166 sectors, data@ 0
------------:/home/jjw# lsblk
NAME                             MAJ:MIN RM   SIZE RO TYPE   MOUNTPOINT
sda                                8:0    0 931.5G  0 disk
+-isw_cgafjgajjg_raid (dm-1)     252:1    0 931.5G  0 dmraid
  +-isw_cgafjgajjg_raid1 (dm-2)  252:2    0 915.6G  0 part   /
  +-isw_cgafjgajjg_raid2 (dm-3)  252:3    0     1K  0 part
  +-isw_cgafjgajjg_raid5 (dm-4)  252:4    0    16G  0 part
sdb                                8:16   0 931.5G  0 disk
+-isw_cgafjgajjg_raid (dm-1)     252:1    0 931.5G  0 dmraid
  +-isw_cgafjgajjg_raid1 (dm-2)  252:2    0 915.6G  0 part   /
  +-isw_cgafjgajjg_raid2 (dm-3)  252:3    0     1K  0 part
  +-isw_cgafjgajjg_raid5 (dm-4)  252:4    0    16G  0 part
sdc                                8:32   0   1.8T  0 disk
+-isw_gbfahdijc_Raid2 (dm-0)     252:0    0   1.8T  0 dmraid
  +-isw_gbfahdijc_Raid2p1 (dm-5) 252:5    0     1T  0 part   /datasource
  +-isw_gbfahdijc_Raid2p2 (dm-6) 252:6    0   839G  0 part   /ftp
sdd                                8:48   0   1.8T  0 disk
+-isw_gbfahdijc_Raid2 (dm-0)     252:0    0   1.8T  0 dmraid
  +-isw_gbfahdijc_Raid2p1 (dm-5) 252:5    0     1T  0 part   /datasource
  +-isw_gbfahdijc_Raid2p2 (dm-6) 252:6    0   839G  0 part   /ftp
sr0                               11:0    1  1024M  0 rom

I noted that my raid status is always Rebuilding. How can I solve this?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.