2

I cannot open the system settings. When I run this in terminal

$ gnome-control-center

I get

(gnome-control-center:11494): GLib-CRITICAL **: g_strsplit: assertion 'string != NULL' failed
Segmentation fault (core dumped)

When I run this as sudo, i.e.:

$ sudo gnome-control-center

the full information is

error: XDG_RUNTIME_DIR not set in the environment.

(gnome-control-center:13379): GLib-CRITICAL **: g_strsplit: assertion 'string != NULL' failed
Segmentation fault (core dumped)

I have tried purging and reinstalling gnome-control-center. I have tried setting the environment variable to /run/user/XYZ. I have tried removing the path to the Anaconda runtime.

My system has an nvidia 1070 card, runs at 128 Gb RAM with some 6960-ish intel processor of about 10 physical cores. I cannot give exact details because the tool I usually use to show those is part of the gnome-control-center tools, and I cannot remember the details here. I have a mostly fresh install of Ubuntu GNOME 17.04. The exceptions are a few packages from the standard repository (Kile, KDevelop, cmake, gfortran, subversion, and a bunch more related to C++-programming and documentations of an extensive code-base with a bunch of computational libraries attached to it). I also have Anaconda, Google Chrome, and Dropbox from outside the repository installed.

(I am completely new to gnome-desktop because of the upcoming abandonment of unity, so I might be missing the most basic of information here --- I cannot even figure out how to show the date in the clock in the menu! --- so please start from low levels.)

Help is most welcome! I need to be able to change a few settings related to language settings.

  • 1
    try setsid gnome-control-center – Arduino_Sentinel Jun 5 '17 at 11:05
  • Arduino_Sentinel, thank you! This worked very well. What can I have done to mess up the program so much? – Richard Jun 6 '17 at 6:40
  • 1
    not so sure,btw, there where some bugs report on early versions to. – Arduino_Sentinel Jun 6 '17 at 7:14
  • @Arduino_Sentinel your command worked for me. But I works unexpectedly without any warning or errors (can't move from "Devices" section) – Philippe Delteil Mar 28 '18 at 21:00
  • I had a similar problem with 16.04 and just restarted the computer :( – Keith Böhler Aug 13 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.