2

I recently bought a Xiaomi Notebook Air 13'.

As a lot of people, I met some issues with the WiFi on Ubuntu (16.04). Basically, the WiFi just did not work.

As answered on ask ubuntu, a simple way to fix this issue is to add blacklist acer_wmi in the file blacklist.conf.

So, my question is not "How to fix this issue?", but my question is "How could I know by myself ( ie. just by looking in command output like lsmod or lspci ) how to fix this issue?

For example, an extract of the output of lspci -vv is the following:

$ lspci -vv
02:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
Subsystem: Intel Corporation Wireless 8260
Control: I/O- Mem+ BusMaster+ SpecCycle- MenWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66Mhz UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ283
Region 0: Memory at a4100000 (64-bit, non-prefetchable) [size=8K]
Capabilities: <access denied>
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

Here, we see that iwlwifi is the module which drives the Wifi controller.

But I cannot find any link (when I use for example lspci or lsmod) between iwlwifi and acer_wmi.

But if I blacklist acer_wmi, the WiFi works fine! Why ?

For information:

$ lsmod | grep acer_wmi
acer_wmi       20480 0
sparse_keymap  16384 2 acer_wmi,dell_wmi_aio
wmi            16384 4 acer_wmi,mxm_wmi,dell_wmi_aio,nouveau
video          40930 3 acer_wmi,nouveau,i915
1

The module iwlwifi is the driver for your wireless device. The module acer_wmi is a helper module that translates key presses, Fn+F8 for example, into action, in your case, 'turn on the wireless radio, please.'

You can gain some clues from the terminal command:

rfkill list all

You may see something like this:

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

As well, you may notice that any presses of the wireless or airplane mode key doesn't enable wireless. In your case, we also see:

$ lsmod | grep acer_wmi
acer_wmi       20480 0
sparse_keymap  16384 2 acer_wmi,dell_wmi_aio
wmi            16384 4 acer_wmi,mxm_wmi,dell_wmi_aio,nouveau
video          40930 3 acer_wmi,nouveau,i915

The original manufacturer of your Xiaomi is probably not both Acer and Dell.

As an experiment, you blacklisted acer_wmi and the wireless works correctly. I believe you found the correct solution!

  • When I blacklist acer_wmi, then rfkill list all shows that acer-wireless is not soft blocked anymore. So, if I understand well, the WiFi did not work before just because acer_wmi prevented it to work, and because my Xiaomi keyboard layout (with the airplaine mode) does not correspond to the acer one and so is not correctly mapped with the wifi activation function of acer_wmi ? – Manu NALEPA Jun 4 '17 at 22:25
  • Correct! May I assume that after acer_wmi is blacklisted and you reboot that acer-wireless is not shown at all in rfkill? – chili555 Jun 4 '17 at 23:06
  • You'r assumption is alright! – Manu NALEPA Jun 5 '17 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.