The Google Chrome and another app icons disappeared from the top panel after I upgraded from Ubuntu 16.04 to 17.04. Tried reinstalling them but to no avail. They are still working, just that the system tray icons won't show.

Anyone encountered the same issue?

Icons present in 16.04 The icons present on 16.04

Chrome and PIA icon gone after 17.04 upgrade Chrome and PIA icons were gone after 17.04 upgrade

  • Are you running Unity or GNOME desktop environments? – heynnema Jun 4 '17 at 17:48
  • @heynnema I tried echo $DESKTOP_SESSION and it outputs ubuntu. I guess that's Unity? – Karl Jamoralin Jun 5 '17 at 2:22
  • Are you using the standard Ambiance or Radiance themes? Do you have any idea what might have happened to make the icons disappear? Can you give more examples of icons that have disappeared? And "system tray" means top panel, or the dock/launcher? – heynnema Jun 5 '17 at 2:45
  • @heynnema Not sure about the themes but I didn't change any of it, so it must be the default one. System tray meaning the top panel where you can also see the date, time, volume icons, etc. I can't think of anything that might have caused it aside from the upgrade from 16.04 to 17.04. The icons are there and working before the upgrade. – Karl Jamoralin Jun 5 '17 at 8:55
  • Can you say exactly what icons are missing? Maybe a screenshot might help me help you. Please edit that into your question and I'll take a look. – heynnema Jun 5 '17 at 13:30
up vote 1 down vote accepted

Reference: http://www.webupd8.org/2017/04/fix-appindicator-not-working-for.html

[Quick update] It looks like Dropbox isn't the only AppIndicator that doesn't work in Ubuntu 17.04 Zesty Zapus (under Unity) due to the change of XDG_CURRENT_DESKTOP from "Unity" to "Unity:Unity7".

Electron applications (such as the new Skype For Linux, WMail, PB For Desktop and many others) are affected as well, but in a different way. For Electron applications, the indicator is not displayed at all in Ubuntu 17.04 Zesty Zapus under Unity.

The fix is similar to the one applied to the Dropbox indicator. Simply run the application with "env XDG_CURRENT_DESKTOP=Unity". For example, to start Skype For Linux, you would use:

env XDG_CURRENT_DESKTOP=Unity skypeforlinux

To make the fix permanent, copy the application desktop file from /usr/share/applications/ to ~/.local/share/applications/, then edit the file and change the "Exec" line by adding "env XDG_CURRENT_DESKTOP=Unity" (without the quotes) immediately after "Exec=".

Some applications are set to start automatically and in that case, you'll have to edit the desktop file from ~/.config/autostart/ in the same way.

Note that some applications overwrite any changes made to their autostart files, located in ~/.config/autostart/. A way around this is to rename the autostart file, then in the application settings, set the application not to start on login. This way, the modified autostart file will be used (which has a different name and contains the workaround).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.