0

I'm trying to reinstall Ubuntu on my laptop with dual-boot and during installation process, when selecting "Reinstall Ubuntu" I'm getting the following message:

The partition table format in use on your disks normally requires you to create a separate partition for boot loader code. This partition should be marked for use as an "EFI boot partition" and should be at least 35 MB in size. Note that this is not the same as a partition mounted on /boot. If you do not go back to the partitioning menu and correct this error, boot loader installation may fail later, although it may still be possible to install the boot loader to a partition

I don't understand why do I get this message, because I have an EFI partition: Disks snapshot

During my previous installation, when I created dual-boot for the first time, I didn't have any problems with the boot loader. Not sure if I even had to use boot-repair after. I've created mu bootable USB using portable Rufus and GPT partition scheme for UEFI.

What should I do with the message? Will choosing a /dev/sda2 in partition screen work or can I expect some problems afterwards?

Thank you for your help!

4
  • Please follow below link. It will help you. askubuntu.com/a/796750/691450
    – Danushka
    Commented Jun 4, 2017 at 11:51
  • 2
    You may need to chkdsk from Windows or dosfsck from Ubuntu live installer (partition must be unmounted). sudo dosfsck -t -a -w /dev/sda2 see also man dosfsck & askubuntu.com/questions/862724/grub2-failed-to-install/…
    – oldfred
    Commented Jun 4, 2017 at 13:47
  • If oldfred's comment doesn't help, please run the Boot Repair utility and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here.
    – Rod Smith
    Commented Jun 5, 2017 at 14:18
  • 1
    @oldfred: Thank you, it did help. Actually, after running those commands, my Ubuntu boot loader was somehow dead and I ended in GRUB menu. But I've could switch to Win boot loader, start booting from USB and this time there so warning like that anymore.
    – Nav
    Commented Jun 6, 2017 at 16:47

0

You must log in to answer this question.

Browse other questions tagged .