I've recently setup QEMU on my server for learning/experimenting with virtualization.

I decided to use a bridge network setup so that the VM would appear on the local network and be visible from external networks.

I followed some steps I found on the Arch Wiki:

After following these steps, the VM uses the bridge interface and is visible on my internal network. However, from inside the VM I cannot connect to any external sources (e.g., run an updater) without it throwing errors (not being able to resolve host names) or hanging.

Server OS: Ubuntu 16.04
VM OS: OpenBSD 6.1

If there's any other information I could provide, just let me know and I get it.

  • Please don't add "solved" to the title. When you can, mark your answer as accepted to indicate that the question is solved.
    – muru
    Jun 6, 2017 at 3:22

1 Answer 1


Forgot to enable NAT: https://wiki.gentoo.org/wiki/QEMU#Host_configuration

I also stopped using QEMU's network bridge helper and manually set up a TAP interface.

After enabled NAT, allowing IP Forwarding with sysctl, allowing ARP proxy, and reinstalled OpenBSD in the VM, it works!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .