5

Sorry about the long post.

I've used Ubuntu once as dual boot with windows 10 long time ago. And yesterday I installed it again. As I had an experience of setting it up on dual boot I was confident enough to do it on my on with the help of some tutorials on internet.

Last time also I got many entries (10+) on Grub boot loader and I've searched through internet and removed them(I thought they are not useful) using Grub-customizer. And at that time it didn't go wrong and I was able to log into Ubuntu or Windows with fewer options in grub menu. So today also I removed the entries which I thought is not important. And now I can't log into the PC as it shows there's no bootable devices detected.

So now I logged on from Ubuntu live cd and was following https://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/ this tutorial but couldn't get pass this last step as I'm getting this error "Installing for i386-pc platform. grub-install: error: failed to get canonical path of `a " .

What have I done wrong ? Is there anyway to fix this ? I mean any way how to get the bootable options (Grub) back ?

edit : This is the way I did it last time Remove useless entries from messed up grub?

marked as duplicate by David Foerster, Rod Smith uefi Jun 5 '17 at 14:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • #OuchFS. As much pain as the tedious installation process where one typo can wreck the story. – neverMind9 Aug 17 '18 at 0:59
1

aufs belongs to the live system. You should install grub into the installed system, and you can use chroot to do that according to the following link to the Ubuntu 'help wiki',

help.ubuntu.com/community/Grub2/Installing#via_ChRoot

Boot Repair is a tool that you might find easier to use, but I think it is worth learning the chroot method.

  • I tried the steps and tried to run gparted and getting the error on it too – Pankaja Paranavitharana Jun 4 '17 at 11:00
  • Please try Boot Repair according to the link in my answer: 1. Post the link to the Boot Info summary (output of the Boot-Info script; 2. Try the Recommended repair; 3. Please describe with your own words what happens when you reboot after running the Recommended repair - Good luck :-) – sudodus Jun 4 '17 at 13:59
  • @Sudodus...I followed the steps and tried..This is the error I'm getting when I run the Recommended repair in Boot Repair. ""GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again." – Pankaja Paranavitharana Jun 4 '17 at 17:30
  • This happens when you make a system, that boots in BIOS mode from a drive with a GUID partition table (GPT). The partitioning details are described in the following link, help.ubuntu.com/community/DiskSpace – sudodus Jun 4 '17 at 17:33
  • By the way, do you want to boot in BIOS mode? Or did it just happen? – sudodus Jun 4 '17 at 17:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.