3

I have the same problem as many others after installing a fresh Ubuntu 16.04. The fix suggested in all cases I can find online is to select a custom file that will auto load grub. The problem I have is that my BIOS does not offer this option to boot.

The problem is discussed here: Bootable device not found after clean install of Ubuntu 14.04 UEFI

But I have no "Security - Select an UEFI file as trusted for executing"

What can I do to get Ubuntu to start in any way? Is there a way to boot into Ubuntu via startup disk to upgrade BIOS or force grub to auto load?

The laptop model is Acer Aspire ES 15 and also called ES1-533-C0L4

Any help is greatly appreciated.

4
  • 1
    Have you updated UEFI from Acer. Some have posted issues with some versions. Original suggestions were downgrade, but newer threads said newest UEFI works. You do have to set a UEFI password to have the trust setting. ubuntuforums.org/showthread.php?t=2348269 & Some use BIOS mode: ubuntuforums.org/showthread.php?t=2348269 & askubuntu.com/questions/706912/… – oldfred Jun 3 '17 at 19:46
  • I am very limited at the moment as I do not have the option many of the suggestions are offering, namely that I can select an UEFI file for trusted execution. Without a way to fix the startup I am unsure what to do? Can I use boot tools for this? Is there anyway to set how things boot without touching the BIOS part? – dinnerisserved Jun 3 '17 at 20:01
  • This shows boot order in UEFI and may show the BIOS entry that has different details. sudo efibootmgr -v Video: youtube.com/watch?v=B4nVdq2nAvY Do you have version 1.08? acer.com/ac/en/GB/content/support-product/6889?b=1 – oldfred Jun 3 '17 at 20:50
  • Please run the Boot Repair utility and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here. This will give us more details about your configuration, which is required to base an answer on more than guesswork. – Rod Smith Jun 4 '17 at 2:06
2

After several hours I finally found a solution, and I cant believe how mind boggling this was. This is what you should do for your Acer Aspire ES series if you want to install Ubuntu.

The main problem is that the BIOS is preventing you from booting anything up but UEFI compatible systems, such as Ubuntu.

  1. Start BIOS by pressing F2.

  2. Disable Secure Boot and change the order of the boot sequence to boot on USB. (My particular Laptop does not have a CD-ROM drive and requires USB as the only option.)

  3. Boot on USB and select to run Ubuntu in live test mode that allows you to get access to terminal commands.

  4. Open terminal and run sudo ubiquity -b to run the installation process for Ubuntu.

  5. Select "Something else" to customize your own partitions.

  6. Create the following partitions as a minimum:

    • The / to store the file system
    • The swap space
    • The UEFI space
  7. Install Ubuntu and press Continue Testing after installation is over.

  8. Mount newly installed file system into:

    sudo mount /dev/sda2 /mnt
    sudo mkdir /mnt/boot/efi
    sudo mount /dev/sda1 /mnt/boot/efi
    for i in /dev /dev/pts /proc /sys; do sudo mount -B $i /mnt$i; done
    

    (where sda2 is the root partition and sda1 is the efi partition)

  9. Load efivars: sudo modprobe efivars.

  10. Reinstall GRUB:

    sudo apt-get install --reinstall grub-efi-amd64
    sudo grub-install --no-nvram --root-directory=/mnt /dev/sda
    
  11. Update the installed GRUB:

    sudo chroot /mnt
    sudo update-grub
    
  12. Move and rename the installed bootloader:

    cd /boot/efi/EFI
    cp -R ubuntu BOOT
    cd BOOT
    cp grubx64.efi bootx64.efi
    

Thanks to Sladek90 for the grub tutorial here: Unable to install Ubuntu on Acer Aspire ES1-533

1

After above steps, I was stuck in 'Secure Boot Failed'.
Figured out below solution.

Step 1: Go to BIOS (by pressing F2 at startup)

Step 2: Turn ON Secure Boot (You might need to set BIOS password before doing this)

Step 3: Select an UEFI file as trusted for executing: HDD0 > EFI > ubuntu > shimx64.efi

Step 4: Add a description and confirm. Save BIOS settings and reboot.

If it doesn't work reset secure boot setting in BIOS

  1. Do Erase all secure boot settings, save settings by pressing F10.
  2. Restart.
1
  • This extra step worked for me after doing the above – Jonno_FTW Jun 20 '20 at 14:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.