1

I Have a problem to boot Ubuntu 1604 on a machine with Windows10 and UEFI. I have a MSi GP62 7RD Leopard laptop with a PCI express SSD and a Hard disk. I use Ubuntu Linux since 804 but this is the first time I have trouble to install it on a machine with Windows installed. I read the official documentation and it won’t help. I tried Ubuntu installations with all BIOS boot combinations (all combinations of Legacy, UEFI with CSM, UEFI, Fastboot enabled, Fastboot disabled) with no result. My Ubuntu 1640 won’t boot from disk.

Before every installation use the following partitioning:

Disk1

  • /dev/sda1 300MiB system EFI system partitioning
  • /dev/sda2 128 MiB Microsoft reserved partition File system type unknown for gparted
  • /dev/sda3 80 Gib ntfs Windows10
  • /dev/sda4 900 MiB ntfs WinRE tools
  • /dev/sda5 93.18 GiB ext4 Ubuntu 1604 for Root file system
  • /dev/sda6 64 GiB swap

Disk2

  • /dev/sdb1 400 MiB ntfs Data (from the default windows installation) flags msftdata
  • /dev/sdb3 ext4 894.16 GiB for /Home file system
  • /dev/sdb4 ntfs 20 GiB Windows Data
  • /dev/sdb2 16.21 GiB ntfs BIOS_RVY (Default windows install) hidden, diag

I made this partitioning with gparted of the Ubuntu 1604 installation DvD (with libparted 3.2). I use /dev/sda5 ext4 for my / partitioning and /dev/sdb3 ext4 for my /Home partition

I also read the article https://www.tecmint.com/install-ubuntu-16-04-alongside-with-windows-10-or-8-in-dual-boot/. This Article says to create a extra partition for the windows ntfs partition. But I have already 2 partitions before my windows partition (sda1 with system EFI partition and sda2 with Microsoft reserved partition). Because sda2 have a unknown file system type for gparted, I do not dare tot wipe sda2 partition, because I do not known I can recovery the partition with clonezilla. I also do not know what function sda2 has for Windows.

What do I have to do, to get my installation working with given partitioning so I can boot from SSD? Which BIOS settings do I have to use?

What do I wrong.

Please help.

1

First, boot the Ubuntu installer in EFI/UEFI mode! That is, do not enable the Compatibility Support Module (CSM), aka "legacy boot" support. Booting the installer in BIOS/CSM/legacy mode is likely to create a mixed-mode installation in which Windows is installed in EFI mode and Ubuntu is installed in BIOS mode. This will be awkward to manage at best. Unfortunately, controlling the computer's boot mode can be difficult, in part because of variability between models in how it's done and in part because manufacturers don't bother to properly document it. A tip, though: Once you've booted the Ubuntu installer, you can drop to a shell and look for a directory called /sys/firmware/efi. If it's present, you've booted in EFI mode; if it's absent, you've booted in BIOS mode. For more on this topic, see my page on the CSM.

Second, you wrote:

I tried Ubuntu installations with all BIOS boot combinations (all combinations of Legacy, UEFI with CSM, UEFI, Fastboot enabled, Fastboot disabled) with no result. My Ubuntu 1640 won’t boot from disk.

This is unclear. Do you mean you could not boot the installation disk? If so, see the section of my CSM page about preparing boot media. Do you mean that you successfully booted the installer and ran through the installation, but that it then did not boot? If so, what symptoms did you see when you tried to boot -- does the computer boot straight to Windows, do you get to GRUB but it then hangs, does GRUB start to launch Ubuntu but it fails in some way, or something else? What error messages, if any, do you see?

If you booted and ran the installation program, you should run the Boot Repair utility and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here. This will give us more details about your configuration, which is required to base an answer on more than guesswork.

Finally, some EFIs are buggy and forget their boot settings. Absent other information, this would be my best guess about what's causing your problem. See this question and my answer to it for information on dealing with this problem. Be aware that's a shot-in-the-dark response, though, and mucking about with those suggestions could even make matters worse; you'd be better served by posting Boot Repair's BootInfo output for analysis.

  • With all BIOS boot combinations I mean, I started the Ubuntu install disk when my firmware of my laptop had the following settings. Option1 FastBoot disabled and Boot mode UEFI. Option2 FastBoot disabled and Boot mode UEFI with CSM. Option3 FastBoot disabled and Boot mode legacy (= BIOS). – user2588998 Jun 4 '17 at 20:13
  • Option4 FastBoot enabled and Boot mode UEFI. Option5 FastBoot enabled and Boot mode UEFI with CSM. Option6 FastBoot enabled and Boot mode legacy (= BIOS). In all these modes I was able to start de Ubuntu installation process. During all those installations, I got no error messages or other messages. – user2588998 Jun 4 '17 at 20:31
  • All installations completed succesfully, except I did not get a boot menu with which I could select between Windows or Ubuntu. I only could boot Windows. Today I "solved" this problem to install the rEFInd boot manager under Windows10 (see rodsbooks.com/refind). Maybe the cause of this problem is the buggy EFI of my MSI laptop. The "rEFInd sollution" worked only with Fastboot disabled and Boot mode "UEFI with CSM". – user2588998 Jun 4 '17 at 20:31
  • The boot mode can be either EFI/UEFI or BIOS/CSM/legacy. Many EFI's provide something like the "UEFI with CSM" option, but that just means that either boot mode is possible; on any given boot, only one will be used. Because rEFInd is an EFI-mode program, a UEFI-only option should work as well with it as an EFI-and-CSM option. (An exception would be if you use rEFInd's ability to redirect the boot to a BIOS-mode boot, but that requires adjusting refind.conf, which you haven't said you've done.) – Rod Smith Jun 5 '17 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.