2

I am a beginner with Ubuntu, and I wanted to try to install it alongside Windows 10 on a new laptop with NVidia GTX 1070 (UEFI). I am running into some strange problems, and I was wondering if someone could help.

I created a bootable USB drive with the latest Ubuntu 16.04 image from Canonical, and I am now trying to boot into it with the "Try Ubuntu without installing" option.

As many others, I have a problem booting into the USB. If I use the USB to boot into the "Try Ubuntu without Installing" option without editing anything, I get the following error:

nouveau 0000:01:00.0: fifo: read fault at .... engine 1f ....

nouveau 0000:01:00.0: HUBO ...

nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22

where the dots represent a bunch of numbers and/or stuff that may not be relevant. The screen then turns black, until I force the laptop to shutdown.

After searching the web, I came across several solutions. One of them was to go into the "Try Ubuntu without Installing" option by pressing "e" and adding "nouveau.modeset=0" in the middle of the second line as follows:

quiet splash nouveau.modeset=0 ---

and pressing f10 to boot. I have also tried adding "nouveau.modeset=0" after the "---" signs, or getting rid of "quiet splash", or using "nomodeset=0", to no avail.

Instead of a completely blank screen, I now get the Ubuntu logo with 5 dots getting filled. However, after about 5 seconds, the screen starts flickering between Completely Black and the Ubuntu logo (with all 5 dots completely filled) every second. After about 20 minutes, it still shows the same behavior, and I just decided to shut it down.

I have tried everything that I could find, such as checking if the USB had any problems, going inside the BIOS and disabling secure boot, and using "nomodeset" instead of "nouveau.modeset=0". It seems that it is a problem with the graphics drivers for Nvidia 1070, but I can't even boot into a USB to download them in the first place.

Anyone has any idea on how I could fix this? It seems that most people got it working with the fixes above, but they are just not working for me.

Laptop Specs:

NVIDIA GTX 1070

Intel(R) Core(TM) i7-7700HQ CPU

SMBIOS Version 3.0

BIOS Mode UEFI

Secure Boot State OFF

BIOS Version American Megatrends Inc.

Thank you for your time! Please let me know!

EDIT1: I was able to get the USB to work by adding also: "acpi=off" in the options. However, now I can only boot my computer with that option in GRUB, and when I do, I need to force shutdown the computer. I tried reinstalling all the nvidia drivers and trying different ACPI options. Still cannot fix the problem, or at least find an ACPI option that allows me to shutdown the system...

2

I found out that the problem was that my laptop had the MSHYBRID option enabled by default in the BIOS. It seems that this is enables NVIDIA Optimus, which allows for the use of both GPUs (the Intel integrated and the GTX 1070), but causes a whole lot of problems with the current version of Ubuntu 16.04.

Luckily, my BIOS had the option to change MSHYBRID to DISCREET within the advanced chipset options, which means that now it will only be using the NVIDIA card.

After that everything worked perfectly. I reinstalled Ubuntu (if the USB didn't boot I would just add the "nomodeset" option to the GRUB Ubuntu option, but do not remember if it was necessary). When booting, I no longer have to change any GRUB options (so maybe the "nomodeset" was only necessary to allow for USB booting)

Still not the best option tho, as it doesn't allow me to change back to the integrated GPU when I am not working on intensive applications. There's a few solutions online, but I am happy with what I have. Fighting with a few wifi problems now...

Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.