I updated my packages today, and now I believe I am having this issue: Bumblebee: [ERROR]Cannot access secondary GPU - error: [XORG] (EE)

The recommended solution is to uninstall xserver-xorg-legacy. However, nvidia-375 now appears to depend on xserver-xorg-legacy.

I want to continue using bumblebee because I want to be able to activate and deactivate my discrete graphics card without restarting, and continue using the GUI even if something goes wrong with the NVIDIA driver.

Is there a way to get nvidia-375 to work with bumblebee, or will I have to go to an older version of the nvidia driver?

EDIT: I found what appears to be a solution

2 Answers 2


These instructions appear to be accurate: http://www.webupd8.org/2016/08/how-to-install-and-configure-bumblebee.html

In my case, because I already had a mostly-working setup, I did this:

My Solution

  1. Add the bumblebee/testing PPA

    sudo add-apt-repository ppa:bumblebee/testing
    sudo apt-get update
  2. Use Synaptic to update Bumblebee, keeping my existing /etc/bumblebee/bumblebee.conf

  3. Add the following lines to /etc/bumblebee/bumblebee.conf

    # Xorg binary to run

    Right after the lines

    # Directory with a dummy config file to pass as a -configdir to secondary X

    Then save and close

  4. Restart the computer, just in case

  5. Make sure everything is actually working by using

    optirun glxinfo

    And seeing that it outputs something different from before, even when used twice in a row


The conclusion of this bug report was what led me to the conclusion that this was the correct solution for now: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815888

The PPA has this rather intimidating warning label:

Unless you're a developer, it's unlikely that you want to use this PPA. Use ppa:bumblebee/stable if you're just a regular user.

Things may break your system in this PPA.

However, there appears to be no Xenial (16.04) in bumblebee/stable, so that isn't an option.


As you said in your own answer you can add the testing ppa. The second way is to simply remove xserver-xorg-legacy and use the stable ppa:

First remove the xserver-xorg-legacy without touching depending packages:

sudo dpkg -r --force-depends xserver-xorg-legacy

Allright - Bumblebee is working again. But apt will give you errors because of missing dependencies. This can be fixed by creating a dummy-package for xserver-xorg-legacy using equivs. First we create a config file using equivs-control:

equivs-control xserver-xorg-legacy

This will create the config file for the new package in the current directory. You can use nano to edit this one:

nano xserver-xorg-legacy

The content of the file should look like this:

    ### Commented entries have reasonable defaults.
### Uncomment to edit them.
# Source: <source package name; defaults to package name>
Section: misc
Priority: optional
# Homepage: <enter URL here; no default>
Standards-Version: 3.9.2

Package: xserver-xorg-legacy
Version: 2:1.18.4-1ubuntu0.2 
# Maintainer: Your Name <yourname@example.com>
# Pre-Depends: <comma-separated list of packages>
# Depends: <comma-separated list of packages>
# Recommends: <comma-separated list of packages>
# Suggests: <comma-separated list of packages>
# Provides: <comma-separated list of packages>
# Replaces: <comma-separated list of packages>
# Architecture: all
# Multi-Arch: <one of: foreign|same|allowed>
# Copyright: <copyright file; defaults to GPL2>
# Changelog: <changelog file; defaults to a generic changelog>
# Readme: <README.Debian file; defaults to a generic one>
# Extra-Files: <comma-separated list of additional files for the doc directory>
# Files: <pair of space-separated paths; First is file to include, second is destination>
#  <more pairs, if there's more than one file to include. Notice the starting space>
Description: Dummy package for nvidia-375.66 update 
 This Package does nothing... it just exists...

Important at this point is the Package name:

Package: xserver-xorg-legacy

And that you have to stage the version so 2:1.18.4-0ubuntu0.2 becomes 2:1.18.4-1ubuntu0.2

If you're done with your config you have to create the package from your config:

equivs-build xserver-xorg-legacy

This will create a package file with the given name and the version. In my case this was xserver-xorg-legacy_1.18.4-1ubuntu0.2_all.deb

Okay, let's install it using dpkg:

sudo dpkg -i xserver-xorg-legacy_1.18.4-1ubuntu0.2_all.deb

Thats it...

xserver-xorg-legacy doesn't do something anymore and apt is happy with no missing dependencies.

Good Luck ;-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.