3

I just installed ubuntu on my laptop. I am not able to upload any file to my web server using ftp or direct from cpanel. I also tried to change folder permission on server . while uploading via cpanel it stuck on middle and never complete and on filezilla it retry 2-3 times and failed to upload. but on same server it is ok to upload files from windows OS. I have no idea what to do. Please help.

edit: I have tried to upload an empty file. It has uploaded. after that I tried to upload files with coding but not succeed.

  • Check with you host and make sure they aren't restrictions, and make sure you have the right credentials for filezilla, and your firewall (if present) isn't blocking traffic – George Udosen Jun 2 '17 at 19:28
  • @George which type of restriction? I am able to upload any file from my desktop on same server. – Suresh Maurya Jun 2 '17 at 19:31
  • 1
    Do you have a firewall enabled? Try to ssh into the server. – George Udosen Jun 2 '17 at 19:32
  • @George thank you for help. I have run this sudo ufw allow ssh command on terminal and problem solved. – Suresh Maurya Jun 5 '17 at 5:01
0

There was some firewall problem. Many programs are built to offer network services. For instance, you can share content, or let someone view your desktop remotely. Depending on which additional programs you install, you may need to adjust the firewall to allow these services to work as intended. ufw comes with a number of rules already pre-configured and you can add your own rules. For instance, to allow SSH connections, enter sudo ufw allow ssh in a terminal. To block SSH connections, enter sudo ufw deny ssh.

To check the current status of ufw, enter sudo ufw status in a terminal.

You can read complete reference here

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.