6

Recently, I bought a Lenovo T470 with preinstalled Windows 10. I install Ubuntu 16.04 in parallel by USB boot. Wifi connections are not displayed as in many other posts.

My home directory is encrypted, in case it is relevant.

After checking, there no Wifi / network device available.

lspci -n -d 14e4

( no response )

iwconfig
enp0s31f6  no wireless extensions.
lo         no wireless extensions.

Neither is any wireless driver displayed in settings.

I suspect that Ubuntu cannot recognize my wireless device. Is there any suggestion / more information needed to solve the problem?

Update 1 :
After Pilot6's comment, I check again and there is still no response.

lspci -knn | grep Net -A2

Update 2 :

lspci
00:00.0 Host bridge: Intel Corporation Device 5904 (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Device 5916 (rev 02)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.6 PCI bridge: Intel Corporation Device 9d16 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Device 9d18 (rev f1)
00:1d.2 PCI bridge: Intel Corporation Device 9d1a (rev f1)
00:1f.0 ISA bridge: Intel Corporation Device 9d58 (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Device 9d71 (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (4) I219-V (rev 21)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device b822
3e:00.0 Non-Volatile memory controller: Toshiba America Info Systems Device 0115 (rev 01)

lsusb
Bus 002 Device 002: ID 0bda:0316 Realtek Semiconductor Corp. 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04f2:b5ab Chicony Electronics Co., Ltd 
Bus 001 Device 003: ID 0bda:b023 Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 058f:9540 Alcor Micro Corp. AU9540 Smartcard Reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Update 3 : More information provided after asking on LaunchPad

sudo lshw -C network
  *-network
       description: Ethernet interface
       product: Ethernet Connection (4) I219-V
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: enp0s31f6
       version: 21
       serial: 54:e1:ad:1f:de:57
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.1-4 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:122 memory:ec200000-ec21ffff

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 16.04.2 LTS
Release:        16.04
Codename:       xenial

uname -a
Linux simon-ThinkPad-T470 4.8.0-36-generic #36~16.04.1-Ubuntu SMP Sun Feb 5 09:39:57 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

rfkill list
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: tpacpi_bluetooth_sw: Bluetooth
        Soft blocked: no
        Hard blocked: no
8
  • Please edit your question and add output of lspci -knn | grep Net -A2. And how is the usb tag related?
    – Pilot6
    Jun 2 '17 at 14:48
  • Sorry, I add it just to emphasize I am booting in from USB. Although I don't think it is relevant, I try to provide as much information as possible.
    – Simon
    Jun 2 '17 at 14:54
  • Then post the output of lspci and lsusb commands.
    – Pilot6
    Jun 2 '17 at 15:09
  • This is a new RTL8822BE device. It is not supported by the installed kernel, or by any kernel.
    – Pilot6
    Jun 2 '17 at 15:30
  • @Pilot6 Is there any link I can check when it would be supported? I suspect there is hardly an estimate on how long it takes...
    – Simon
    Jun 2 '17 at 15:41
6

Since you have the 4.8 kernel, try

sudo apt-get install git build-essential
git clone https://github.com/rtlwifi-linux/rtlwifi-next.git
cd rtlwifi-next
make
sudo make install

Reboot

It should compile with a few warnings with the 4.8 kernel

Lets disable the power save in the module

echo "options rtl8822be ips=N" | sudo tee /etc/modprobe.d/rtl8822be.conf

And we will use the next command to keep Network Manager from attempting to enable power management

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Reboot

4
  • Thanks Jeremy31. Indeed I could now see wifi options and is able to set up connections. However, whenever I access any network, the wireless network status changes to disconnect. Only the wifi I connected shows up now, but the signal drops to zero. If I restart my network manager, no wifi is visible, including the previously connected one.
    – Simon
    Jun 26 '17 at 2:46
  • Thanks Jeremy31. At first, I could see wifi and is able to set up connections. However, whenever I access any network like browering with chrome, the wireless network status changes to disconnect. After so, only the wifi I connected shows up, but the signal drops to zero. Restarting network manager did not work. However, rebooting my laptop gets back those disappeared wifi.
    – Simon
    Jun 26 '17 at 15:01
  • After some more research on the problem, I suspect the wireless device is blocked. I will put it as another post then. Thanks for your help.
    – Simon
    Jul 24 '17 at 2:15
  • I was facing a similar problem in my recently installed ubuntu 17.04 on my OMEN Laptop 17-an0xx: no wireless driver was loaded, but after instaling rtlwifi-next and rebooting the wireless now works just fine
    – emont01
    Sep 15 '17 at 8:12
0

I recently ran into this same issue with a HP Laptop (14-cf0xxx) where I was attempting to install Fedora 28. Fedora 28 comes with this kernel:

kernel-4.16.3-301.fc28.x86_64

With this version, the rtl* WiFi hardware would not work. However when I updated the system using the Ethernet just so I could get access to the Internet, this newer version of the Linux kernel worked without issue:

kernel-4.18.5-200.fc28.x86_64

A simple update to the packages resolves this issue, saving effort in having to build the module by hand.

NOTE: This is the WiFi hardware I was dealing with:

$ lspci | grep Realtek
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.