5

I want to add a new Bluetooth device. But it seems like Bluetooth is disabled and nothing helps add a new device.

My system: ThinkPad T470s; Ubuntu 16.04 LTS; encrypted Hard drive (I tried it before with a non encrypted HDD and it would work fine). After I setup the system I also updated it and then restart. Now I wanted to connect a bluetooth keyboard.

Results of rfkill list:

2: tpacpi_bluetooth_sw: Bluetooth
    Soft blocked: no
    Hard blocked: no
18: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

So, I assume a Bluetooth adapter exists.

When I go to the bluetooth hardware in the system settings:

enter image description here

... and try to turn bluetooth on, then you can see (at the top right corner) the Bluetooth icon disappears (for some reasons):

enter image description here

I tried to reinstall bluez and also install blueman.

When I open the Bluetooth manager, you can see that none of the icons are clickable.

enter image description here

I also did this:

sudo gedit /etc/rc.local

and added the following line before exit 0

rfkill unblock bluetooth

...and then restart. Then I repeated the steps mentioned above. Same result: Cannot add new devices.

2
  • 2
    Please edit your question and add output of lspci -knn | grep Net -A3; lsusb; dmesg | grep -i blue terminal command.
    – Pilot6
    Jun 2 '17 at 14:09
  • Due to your hint I could solve it. Thanks @Pilot6 See answer. Jun 2 '17 at 14:26
2

It seems like ibt-12-16.sfi was missing. I downloaded it from this site and copied it to /lib/firmware/intel

1
  • I see ibt-12-16.sfi in the mentioned directory location, but my visibility is still disabled any ideas? Jul 4 '20 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.