I recently installed Ubuntu 17.04 on my computer and I am a new Linux user.

I activated my Bluetooth and tried to send some pictures from my phone (after connecting the device to the laptop) but it failed.

I tried then sending a picture from my laptop to my phone and it didn't do anything.

I changed the Share Settings and activated the Bluetooth sharing as it is said in the documentation but...

What to do? Thank you


From the terminal, run (as normal user)

systemctl --user start obex

That worked for me… as it enabled me to send – for example – files to my phone via bluetooth.

For a fix that works accross reboots, run (as normal user)

systemctl --user enable obex

Which creates an according symlink. This is a set-and-forget thing, enabling file transfers permanently so you don't need to start obex every time.

Also see https://bugs.launchpad.net/ubuntu/+source/bluez/+bug/1645631


I had the same issue. After banging my head against a selection of walls, I came across a post somewhere which recommended running the command


as your own user in a terminal. That seems to have done it for me. Didn't require installation of blueman, obex-ftp, etc.

I now added that command to my 'start-up application' list and the sun keeps on shining..

  • So did the solution work for you too? If it did, maybe you want to vote for it by pressing that ^ button on the left :-) – Lobsta Jul 7 '17 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.