I recently tried upgrade from 9.04 to 9.10 on my netbook, but something went wrong, and X session hang up. After reboot I still can log to system, but Gnome is rather broken.

I found that I can issue command "sudo do-release-upgrade" to continue upgrade, but it tries to do upgrade from 9.10 to 10.04, even I have "jaunty" in /etc/apt/sources.list.

I guess thats because some information in system has 9.10 in version, like "lsb_release -a" gives "Release: 9.10"

My question is: Where I should change release information, so "sudo do-release-upgrade" can do upgrade 9.04 -> 9.10, not 9.10 -> 10.4

I know how to copy /home dir and reinstall system with preservation of this dir, I'm just curios if there is way to rescue sys by working with apt-get, aptitude, and dpkg. I'm sure that all changes were made only by these tools so maybe there is way to fix it. And, yes I know that 9.10 is a little bit outdated but it is still supported and I use it because of software compatibility.

  • Trying to fix your 9.10 installation is folly. You need to backup your data and take note of your installed apps, then do a clean install of 10.10. Fixing a broken install is difficult, and even if you succeed, you'll have an installation two release cycles behind. It's simply not worth the trouble. – Evan Kroske Oct 24 '10 at 18:43

It's probably better to run sudo apt-get -f install and sudo dpkg --configure -a instead. That should install/upgrade all the packages that were marked by the upgrade process but didn't get installed yet because of the crash.

  • "sudo apt-get -f install" gives me output that says: "/usr/sbin/invoke-rc.d:274 /sbin/runlevel: not found" – Damian Melniczuk Oct 24 '10 at 19:10
  • After trying to install initscripts I have: "dpkg: cannot find "update-rc.d" in path". – Damian Melniczuk Oct 24 '10 at 19:23
  • "/sbin/runlevel not found" means the upstart package isn't installed completely/correctly—that's really bad. – JanC Oct 24 '10 at 19:36
  • Did you also try the dpkg command I gave? – JanC Oct 24 '10 at 19:37
  • Yes, I tried also dpkg command. – Damian Melniczuk Nov 15 '10 at 17:11

This command helped me, when a power cut interrupted my install. But I was upgrading from Lucid to Maverick.

sudo apt-get dist-upgrade

Just as an anecdote, I once copied the contents of /var/cache/apt from 8.10 into 9.10, so I could roll-back to 9.04. Suffice to say, I had to do a clean install later.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.