36

Is there a GUI for Docker on Ubuntu like Kitematic? (included in Docker toolbox but this only runs on Windows and Mac at the moment?)

enter image description here

7 Answers 7

44

Kitematic is available for Ubuntu (although the website itself doesn't advertise it), you can get it from the Github repository.
Simply extract the downloaded file and install it with your favorite package manager.

2
  • 1
    To save future readers one click, this tool is archived and the authors suggest using Docker Desktop instead. Commented Jan 4, 2022 at 17:46
  • Deprecated project. The official manger (Docker Desktop) is now available in Linux: docs.docker.com/desktop/linux/install
    – mbnoimi
    Commented Jul 13, 2022 at 15:10
18

If you already have docker installed, Portainer does a good job on this.
It runs in a light-weight docker container itself. It's open source and exposing a webinterface.

Just run:

docker run -d -p 9000:9000 \  
-v /var/run/docker.sock:/var/run/docker.sock \  
portainer/portainer

And point your browser to http://localhost:9000.
Check out some more background at Portainer.

17

You can try DockStation too.

It's free for personal and commercial purposes and available for Linux, macOS & Windows. There is an AppImages for Linux too.

DockStation Screenshots

8

This site is very useful for finding alternative software for anything (!alt docker gui in duckduckgo for a quick search of it). The top rated alternative right now is Rancher but I greatly prefer Dockstation

1

Cockpit is available on Ubuntu 18.04 LTS and there is a docker module as well. Once I got cockpit-ws installed and running, I was able to download and launch containers easily.

1

if you choose to download Kitematic for ubuntu; Make sure that the user running kitematic belongs to group docker.

0

For current users like me on Ubuntu 21.04 these answers are dated and should be annotated such like:

  • Kitematic : is now archived. But if like me you tried to install on 21.04 it wont work as the dependencies have be deprecated.
  • Dockstation : didn't work for me and I don't want to spend hours trying to find out why and maybe not being able to fix.

So I tried Portainer and it works with little fuss so I would recommend this. But its not the latest version and I need to do some work...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .