I formated my PC and I'm trying to upload a new version on my app to my PPA. But I'm stuck with the next issue...

As you can see, I have my GPG key, I uploaded and confirmed in Launchpad:

costales@dev:~/Desktop/anoise-0.0.26$ gpg --fingerprint
costales@dev:~/Desktop/anoise-0.0.26$ gpg2 --fingerprint
pub   rsa2048/A0E929E6 2017-06-01 [SC]
      Key fingerprint = 41B4 81ED D84B AAC8 43E1  E72E 34DF 00C2 A0E9 29E6
uid         [ultimate] costales <costales.marcos@gmail.com>
sub   rsa2048/959B785C 2017-06-01 [E]


I create the sources (system didn't ask for my private GPG password):

costales@dev:~/Desktop/anoise-0.0.26$ dpkg-buildpackage -S -sa -rfakerootdpkg-buildpackage: source package anoise
dpkg-buildpackage: source version 0.0.26
dpkg-buildpackage: source distribution trusty
dpkg-buildpackage: source changed by costales <costales.marcos@gmail.com>
 dpkg-source --before-build anoise-0.0.26
 fakeroot debian/rules clean
dh clean 
pyversions: missing X(S)-Python-Version in control file, fall back to debian/pyversions
pyversions: missing debian/pyversions file, fall back to supported versions
    python setup.py clean -a
running clean
'build/lib.linux-i686-2.7' does not exist -- can't clean it
'build/bdist.linux-i686' does not exist -- can't clean it
'build/scripts-2.7' does not exist -- can't clean it
WARNING: the following files are not recognized by DistUtilsExtra.auto:
    find . -name \*.pyc -exec rm {} \+
 dpkg-source -b anoise-0.0.26
dpkg-source: warning: no source format specified in debian/source/format, see dpkg-source(1)
dpkg-source: info: using source format '1.0'
dpkg-source: info: building anoise in anoise_0.0.26.tar.gz
dpkg-source: info: building anoise in anoise_0.0.26.dsc
 dpkg-genchanges -S -sa >../anoise_0.0.26_source.changes
dpkg-genchanges: including full source code in upload
 dpkg-source --after-build anoise-0.0.26
dpkg-buildpackage: source-only upload: Debian-native package
 signfile anoise_0.0.26.dsc

 signfile anoise_0.0.26_source.changes

But I can't upload to my PPA:

costales@dev:~/Desktop/anoise-0.0.26$ dput ppa:costales/anoise ../anoise_0.0.26_source.changes 
Checking signature on .changes
gpg: Signature made jue 01 jun 2017 22:14:13 CEST using RSA key ID A0E929E6
gpg: Can't check signature: public key not found
Error verifying signature on ../anoise_0.0.26_source.changes.

Any idea? Thanks in advance!


anoise_0.0.26_source.changes: https://paste.ubuntu.com/24741506/

dput --debug ppa:costales/anoise: https://paste.ubuntu.com/24741500/

  • 1
    Could you please include the content of anoise_0.0.26_source.changes and the output of dput --debug ppa:costales/anoise in your quest? That may uncover more info on what's happening here. You can also try to skip the signature check with --unchecked. – David Foerster Jun 1 '17 at 21:29
  • @DavidFoerster Added paste.ubuntu.com/24741500 paste.ubuntu.com/24741506 Thanks in advance! – Costales Jun 1 '17 at 22:03
  • Could you please run dput --debug ppa:costales/anoise in the same working directory as in your question? Obviously the upload will fail if dput can't find a changes file. :-) – David Foerster Jun 1 '17 at 22:09
  • @DavidFoerster Sure :) paste.ubuntu.com/24748968 – Costales Jun 2 '17 at 14:43
  • @DavidFoerster The --unchecked flash on dput uploaded the package to the PPA. Thanks a lot mate! Could you reply as formal comment for my +1 :) A big hug! – Costales Jun 2 '17 at 15:20

For whatever reason GnuPG doesn't find your own public key in your key ring when it tries to verify the signature on the changes file. I tried to run the verification myself successfully, so it's no malformed changes file or something like that.

As a workaround you can run dput with the --unchecked flag to skip the signature verification.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.