2

Under Ubuntu 16.04 I needed to install Firefox. I installed it via terminal, but the problem is that I can`t make it default via Default Applications tab because it is just not present there. How is it possible to fix this?

UPD: My output for

sudo update-alternatives --config x-www-browser

is:

Selection    Path                           Priority   Status
------------------------------------------------------------

0            /usr/bin/google-chrome-stable   200       auto mode

1            /usr/bin/chromium-browser       40        manual mode

* 2            /usr/bin/firefox                40        manual mode

3            /usr/bin/google-chrome-stable   200       manual mode

But still links in Skype, for example, opens with Chrome. And Firefox is not listed in default applications

UPD2:

update-alternatives --query x-www-browser gives:

Name: x-www-browser

Link: /usr/bin/x-www-browser

Status: manual

Best: /usr/bin/firefox

Value: /usr/bin/firefox

Alternative: /usr/bin/chromium-browser
Priority: 40

Alternative: /usr/bin/firefox
Priority: 200

Alternative: /usr/bin/google-chrome-stable
Priority: 30
  • 1
    Firefox is the default browser in Ubuntu. It is also the only web browser preinstalled. – mikewhatever Jun 1 '17 at 17:41
  • Not in my case, maybe I have some special edition, it was preinstalled on my Dell laptop – wasd Jun 1 '17 at 18:27
4

There are a lot of different situations which Ubuntu comes without a browser in them, e.g: minimal installation using network installer.

Make sure "Firefox" is installed:

$ dpkg -l firefox | grep ^ii
ii  firefox        53.0.3+build1-0ubuntu0.16.04.2

If it's not install it:

$ sudo apt install firefox -y

Set Firefox as your default browser:

xdg-settings set default-web-browser firefox.desktop

If it did not worked follow the bellow instruction:

Give the chrome a lower priority:

sudo update-alternatives --install /usr/bin/x-www-browser x-www-browser /usr/bin/google-chrome-stable 30

Then use update-alternative to make "Firefox" your default browser:

$ sudo update-alternatives --config x-www-browser

It will show you available browsers:

  1            /usr/bin/chromium-browser   40        manual mode
  2            /usr/bin/firefox            40        manual mode

Pick the one you want, in this case 1 or any other you like and press enter.

  • Updated question – wasd Jun 1 '17 at 18:36
  • @wasd updated the answer ;) – Ravexina Jun 1 '17 at 19:17
  • I set lower priority to google-chrome, but links still are opened with chrome, which is choosen in Default applications and Firefox is not present there, so I can't change it ( – wasd Jun 2 '17 at 5:55
  • Give firefox a higher priority then, something like 200. see what happens. – Ravexina Jun 2 '17 at 6:46
  • Done, still no changes. Or should I restart laptop? – wasd Jun 2 '17 at 6:48
0

I just use: update-alternatives --config x-www-browser

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.