1

I have a problem with my sound driver or the software managing my sound output device. Strangely sometimes it is working, and sometimes it doesn't work and then I just can't get it working propperly again. This is what happens: the software doesn't detect my headphone from being plugged in, initially no output device produces any sound. However after changing INput device, the integrated speaker on my laptop is able to produce sound.

The goal of course is to be able to output sound over the device plugged in at the headphone jack.

Here is some extra information.

owner@swagtop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3266 Analog [ALC3266 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

owner@swagtop:~$ lspci | grep -i audio
00:1f.3 Audio device: Intel Corporation Device a171 (rev 31)

Even more: http://www.alsa-project.org/db/?f=fbf1f7515a49816c3ba3bc84b20540cd52e41aae

My test setup. test setup

The driver my sound card depends on. http://www.dell.com/support/home/us/en/4/Drivers/DriversDetails?driverId=876VV


Sorry couldn't stop typing, now i will describe a small use case what happen before this problem started when the driver was still working probably.

  1. Boot with headphone jack plugged in.
  2. Removed headphone cable from headphone jack.
  3. Plugged in another headphone jack cable (5.1 surround system).
  4. Ubuntu asks what device is plugged in (this doesn't happen anymore as well).
  5. I selected headphones, since there is no specific option for surround.
  6. Removed surround system cable from headphone jack.
  7. Plugged in the headphone cable.
  8. Pressed cancel where ubuntu asks to select the type of output device.

No unusual things where happing before I booted up again.

0

Use on command line the graphical tool alsamixer to get rid of any soundproblems, it's gui is very well self explanatory.

  • Thanks for the tip but I already tried that, check out my test setup. – Fleuv Jun 1 '17 at 13:45
  • Yes, very nice! You already have checked if there is a collison between your Headphone and Headset and tried to un-mute everything?? – John Goofy Jun 1 '17 at 13:57
  • Yes, but still no output trying to do this now wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS – Fleuv Jun 1 '17 at 13:59
  • Okay shouldn't have done that... no soundcard – Fleuv Jun 1 '17 at 14:04
  • You don't have a soundcard? Or you just have a wrong one? I hope I don't need to mention, that you have to reboot after any change, even if you are using alsamixer. – John Goofy Jun 1 '17 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.