0

Please am still new to unix. Am learning at the moment. Am using Ubuntu 16.04LTS on a virtual machine(oracle). I want to try the command 'whatis', but the book am reading says this:-

Before running whatis the first time on your system — particularly if you’re running a standalone machine using FreeBSD, Linux, or Darwin — you’ll want to run the makewhatis at /usr/ libexec/ makewhatis, which creates the whatis database by scanning the command names from the existing manpages.

I tried running /usr/libexec/makewhatis, I got this

bash: /usr/libexec/makewhatis: no such file or directory

I tried doing sudo apt install makewhatis, I got this, after reading package lists, building dependency tree, reading state information

E: Unable to locate package makewhatis

When I did whatis cat though, I got the result I was expecting. Please I just want to know if I don't need to run /usr/libexec/makewhatis, on my system, to use whatis the first time, and everything is fine.

2

/usr/libexec doesn't exist on Ubuntu by default. Hence the error is proper. Your book might be slightly outdated. To quote this article:

Enter makewhatis. This command creates the whatis database files used by both apropos and whatis. They are located in each ../man directory and catalog the manual files in each of the individual cat? and man? subdirectories.

If you read the manual for whatis you'll see that it's not necessary to be done anymore on modern systems(emphasis added):

index databases are used during the search, and are updated by the mandb program. Depending on your installation, this may be run by a periodic cron job, or may need to be run manually after new manual pages have been installed.

1
  • Cheers mate. Understood – Evan Jun 1 '17 at 8:46
0

For ubuntu 16.04 it is not necessary to execute the

/usr/libexec/makewhatis

command, only execute the command

whatis cat

whatis cat has the same result as man -f cat

1
  • Cheers mate. Do you mind if I ask why not so, for Ubuntu 16.04 – Evan Jun 1 '17 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.