0

This question already has an answer here:

I have some tenacious problem with installing my printer driver since I set up Ubuntu 14.4 new. Until this time everything worked fine and I could use/install the printer driver successfully . Also I am quite sure, that I didn't change any settings. Now it isn't possible anymore to install the driver again. Every time I get the message "permission denied".

I read about the problem of access rights and how to show/change setting. At this point I am not sure. I am logged in as admin and if i show right settings for "install.sh" this is shown:

jam@jam-GA-880GM-USB3:/media/jam/Western Digital WD20/Software/Samsung Druckertreiber/Ubuntu-Linux/uld$ ls -l
insgesamt 19
drwx------ 1 jam jam 4096 Dez 12  2014 i386
-rw------- 1 jam jam  446 Dez 12  2014 install-printer.sh
-rw------- 1 jam jam  446 Dez 12  2014 install-scanner.sh
-rw------- 1 jam jam  848 Dez 12  2014 install.sh
drwx------ 1 jam jam 4096 Feb 10  2015 noarch
-rw------- 1 jam jam  328 Dez 12  2014 uninstall-printer.sh
-rw------- 1 jam jam  328 Dez 12  2014 uninstall-scanner.sh
-rw------- 1 jam jam  383 Dez 12  2014 uninstall.sh
drwx------ 1 jam jam 4096 Dez 12  2014 x86_64
jam@jam-GA-880GM-USB3:/media/jam/Western Digital WD20/Software/Samsung Druckertreiber/Ubuntu-Linux/uld$ ^C

If a go to properties of the file "install.sh" there is written "read and write" for me/admin. But for "jam"-account there is only "none". But "jam" is my admin-account. If i want to change settings for "jam"-account, it imediately jumps back to "none". Only of I copy the file "install.sh" to the hard disk, I can change the access rights to "read and write". But also I get the message "permission denied" when I try to install.

So a lot of text. I wrote every backround information to help professional ubuntu users here to help me. I hope

marked as duplicate by David Foerster, Eric Carvalho, Zanna, Sumeet Deshmukh, Elder Geek Jun 1 '17 at 15:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Have you tried chmod 777 install.sh – ADDB May 31 '17 at 19:07
  • 2
    @ADDB: Please don't recommend 0777 a.k.a. “please-hack-my-system-and-destroy-my-data” permissions for no apparent reason! There's almost never a reason to do that because it can be avoided with more sensible modifications. – David Foerster May 31 '17 at 19:21
  • @DavidFoerster it's one of the most common and easiest way to do this. I'd never recommend it on important scripts, but this is a printer driver so... – ADDB May 31 '17 at 20:20
  • 3
    @ADDB: What's easier about chmod 777 than just chmod 755 or even chmod +x? Why would you need to give other users permission to modify files if the intention is to read and/or execute them? Please don't educate users to do stupid things that aren't any simpler than a sane solution. (Personally I'm all for teaching people symbolic access permission mnemonics instead of arcane octal bit masks). – David Foerster May 31 '17 at 23:55
3

The problem here is that you don't have permission to execute it.

If you run chmod +x * in the folder with the install.sh file, that will give you permission to execute any of the scripts in that folder.

  • Hey togehter! Thanks a lot for so many and quickly answers. I think I have a fundamental deficit of knewledge of rights assignment in Ubuntu. I used "chmod +x *" in the terminal (opened in the folder with "install.sh") But the result is the same. After command "sudo sh install.sh" I got the same message: "Permission denied" Also if I copied the folder of printer drivers to the hard disk ("downloads"-folder) where Ubuntu is installed. – HrJames Jun 5 '17 at 12:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.