1

Suddenly (and I'm not sure if this was after a recent Ubuntu update or a Thunderbird one) Thunderbird no longer shows "Network" locations in the 'Attach File(s)' window. Normally below "Bookmarks" is another section "Network" which shows my network locations, however this entire section is now missing.

There is now no way of attaching a file existing anywhere on the network to an outgoing email.

Nautilus can see and access all the network locations 100% fine. Drag/drop into the outgoing email from Nautilus will attach a network file to the email but Thunderbird refuses to send it and throws up a "Send Message Error":

Sending of the message failed. There was an error attaching smb://mypc/my documents/myfolder/file.xls. Please check that you have access to the file.

Attaching network files to an email in Thunderbird and on Ubuntu 14.04 has worked fine for two years. Ubuntu updates and Thunderbird updates always added via the Software Manager etc. Not 3rd party.

I initially raised this as a bug (given the rock solid performance before): https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1694129 - now I'm not so sure but it's always worked fine until now.

Update

Uninstalled and reinstalled Thunderbird from Software Centre. No change.

I've found a workaround to "see" the network from Thunderbird's 'Attach' Dialogue:

  1. Navigate to the desired Network folder in Nautilus (and minimise)
  2. Then clicking on "Attach" in compose email view opens the Attach dialogue showing the desired Network folder and does allow attachments.

Still can't work out why the entire "Network" section is missing from the Thunderbird Attach dialogue though.

  1. Using Profile Manager I created a brand new profile (in case my regular profile had somehow corrupted). I created one new email account.

No change at all "Network" is still absent from the Attach files dialogue.

I'm all out of ideas.

Update 08 June 2017: Status now confirmed as bug

https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1694129

closed as off-topic by Zanna, pomsky, David Foerster, George Udosen, Eric Carvalho Nov 1 '17 at 21:32

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Zanna, pomsky, David Foerster, George Udosen, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

0

I managed to attach a file by browsing to the network file from the file manager, then right clicking to open with Thunderbird.

Not the answer you're looking for? Browse other questions tagged or ask your own question.