I install virtualBox on Ubuntu 16.04, but after install and create new virtual Host shows this error:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please install virtualbox-dkms package and load the kernel module by executing

modprobe vboxdrv

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

When I try to run sudo modprobe vboxdrv, I get this error:

$ sudo modprobe vboxdrv
modprobe: ERROR: could not insert 'vboxdrv': Required key not available

How can I address this modprobe vboxdrv error?

  • 1
    Do you try ‘sudo modprobe vboxdrv‘ ? May 31, 2017 at 11:01
  • See this question is exactly the same just a few hours ago. Maybe one of the comments will help you aswell since Jimmi hasn't said yet what helped him.
    – Ziazis
    May 31, 2017 at 11:17
  • @AliRazmdideh OP answered your question in this comment: askubuntu.com/questions/920689/…
    – Flimm
    May 23, 2023 at 17:07

5 Answers 5


As the first step run this command:

sudo modprobe vboxdrv

If it's not helpful run these commands:

sudo apt update
sudo apt install --reinstall linux-headers-$(uname -r) virtualbox-dkms dkms

Then reboot your system and after reboot run this command:

sudo modprobe vboxdrv

And if it doesn't work you must disable Secure Boot in your BIOS/UEFI settings because Secure Boot prevents unsigned modules from being loaded.

  • 9
    Hi, After run sudo modprobe vboxdrv, show this error: modprobe: ERROR: could not insert 'vboxdrv': Required key not available
    – mySun
    May 31, 2017 at 13:08
  • 1
    @mySun Is your problem solved ? If my answer is not be helpful , please read this post instructions to solve Required key not available issue : askubuntu.com/questions/760671/… May 31, 2017 at 13:39
  • 4
    I read this post and find my problem :-) Thank you.
    – mySun
    May 31, 2017 at 15:19
  • 2
    I didn't need to reboot but your apt install method did work. Nov 6, 2017 at 2:58
  • What's the best way to automate it at boot? Should I put it into /usr/lib/modules-load.d?
    – yuranos
    Jul 18, 2018 at 15:34
  1. Uninstall virtualbox-dkms and its configurations by running the below commands:

    sudo apt-get remove virtualbox-dkms
    sudo apt-get remove --purge virtualbox-dkms
  2. Install Linux headers and Linux image by running the below command:

    sudo apt-get install -y linux-headers-amd64 linux-image-amd64
  3. Install virtualbox-dkms

    sudo apt-get install -y virtualbox-dkms
  • 2
    My system cannot find linux-headers-amd64 or linux-image-amd64 Trying apt dist-upgrade instead. Jun 4, 2018 at 9:26
  • 1
    linux header installation has to be generic sudo apt install --reinstall linux-headers-$(uname -r) virtualbox-dkms dkms
    – Nav
    Nov 23, 2018 at 3:16

In my case it has to do with UEFI being active. In that case, unsigned kernel modules like vboxdrv aren't loaded.

More info here: Could not load 'vboxdrv' after upgrade to Ubuntu 16.04 (and I want to keep secure boot)


Like @david.perez exposed, it can be solved by disabling the UEFI Secure Boot:

  1. do 'Power Off / Restart'
  2. at the very first screen, select 'UEFI settings'
  3. in the Bios interface, browse until 'UEFI' tab
  4. change 'Enabled' to 'Disabled', save and exit

I'm using 20.04 and I followed the steps from Zanna described above.

Then I got this error when trying to execute the last command:

Error: modprobe: ERROR: could not insert ‘vboxdrv’: Operation not permitted

I followed this guide to fix the permission error:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .