6

I have only United States for my Region and Formats probably because I have a custom installed Ubuntu!

enter image description here enter image description here

How do you install another one?

update

This is why it doesn't work...how to fix this error?

enter image description here

  • You want to set a new timezone? or locale? – Ravexina May 31 '17 at 8:37
  • No, I want to set new Measurment and Times – lewis4u May 31 '17 at 8:38
  • Edit your question add more details about what exactly you want in which program, etc. – Ravexina May 31 '17 at 8:39
  • I have made another screenshot. I want to change that to German. Language is English and i want the formats to be German. But i can't add any. – lewis4u May 31 '17 at 8:40
  • Did you install the german language? If not do so. That will also add the options to pick the times as used in Germany. – Rinzwind May 31 '17 at 8:50
7

First reinstall locale package:

sudo apt --reinstall install locales

Open this file:

sudo nano /etc/locale.gen

Find this line: # de_DE.UTF-8 UTF-8, uncomment it so it's now: de_DE.UTF-8 UTF-8. Save the file and run:

sudo locale-gen

see if you have German now.

| improve this answer | |
  • Wait till i update next ss – lewis4u May 31 '17 at 9:01
  • Updated, please have in mind that i have a custom installed Ubuntu – lewis4u May 31 '17 at 9:06
  • see my update... – Ravexina May 31 '17 at 9:08
  • There is one more thing....when i run locale in Terminal i get all sort of settings....and i want to change some of them. where is that file, what is the name of that file?? – lewis4u May 31 '17 at 9:30
  • 1
    You mean things like LC_TIME, etc? the file is /etc/default/locale the command is: e.g sudo localectl set-locale LC_NUMERIC=localecode – Ravexina May 31 '17 at 9:38
1

If you want German region formats, I think this is a way:

  1. Switch to German language, which will generate a few German locales.
  2. Switch back to English language.
  3. Now you should find some German region options.
| improve this answer | |
  • I have found the catch...I will edit my question and then you will see why I couldn't make it – lewis4u May 31 '17 at 9:01
  • Updated, please have in mind that i have a custom installed Ubuntu – lewis4u May 31 '17 at 9:06
  • 1
    @lewis4u: Hmm.. Then I'd recommend you to run the command sudo apt install --reinstall locales. – Gunnar Hjalmarsson May 31 '17 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.