2

Basically, I can ping from my Linux server to Windows (when I disable the firewall), but I can't ping from Windows to Linux, whether I disable the ufw-firewall or not. It just doesn't reach it. My Ubuntu uses a Network Bridged Adapter, as well.

Linux server's IP:

10.88.77.111

Windows IP (Wi-Fi):

192.168.0.110

Because of this, I think, I cannot connect to the linux server using SSH as well. Firewall can't be the issue, because I disabled both of them.

EDIT:

I've said this in the comment section below, but might as well repeat it here. No, SSH does not work. It gives the famous error: "Network error: Connection timed out", and I still haven't been able to fix that problem.

Second EDIT:

Yes, my Ubuntu host is on a Virtual Machine (VirtualBox). I'm just trying to connect my Ubuntu server (which is on a VM), to my Windows host, through SSH. But that doesn't work. Since that didn't work, I tried to ping the two, and one of two was successful, which is strange. If it's the Network Bridge Adapter which is causing a problem, what do you suggest I take? And also, I HAVE done SSH before, and it worked. Only now, after a couple of months, I'm trying to do SSH again, and now it's failing, for some weird reason. Should I try and change the IP of my Ubuntu?

Third EDIT:

It's an Ubuntu Server. Here are the two relevant config-files of my server:

/etc/network/interfaces

enter image description here

/etc/hosts

enter image description here

  • 3
    Did you try SSH-ing? Ping is one of those odd protocols where things don't necessarily reply the way they should, or is filtered out on the router between subnets, so sometimes SSH (tcp) will work, but Ping (ICMP) won't. – Thomas Ward May 30 '17 at 17:55
  • 1
    You could install Wireshark on Windows and tcpdump on Linux to see the actual packets. Apparently, there is one more device involved, is it the WiFi router? – MKaama May 30 '17 at 18:05
  • TRY nmap instead and then add to question :) – Sharad Gautam May 30 '17 at 18:17
  • Yes, I tried to SSH. It says "Network error: Connection timed out". – ZstrZr May 30 '17 at 19:38
  • I already have Wireshark, but what exactly do I have to look for when troubleshooting this particular scenario? I do see the 4 pings failing, but it's not really giving me information with which I know how to deal with. Any further details? And, as for "Sharad Gautam", what is "nmap"? Personally never heard of it. – ZstrZr May 30 '17 at 19:46
1

We need a little more information on your network setup to answer your question fully, but I believe I know at least what is causing the issue.

Assuming:


1) Both the Windows and Linux computers are supposed to be on the same local network.

2) The Linux server is not a virtual machine.

3) You are using bridged connections on your Windows machine to share its wireless connection to the Linux server through ethernet. (You bridged Wireless and Ethernet in Windows to get a connection to Linux.)


Then the problem is likely your network bridge. Your router assigned the local IP 192.168.0.110 to the Windows machine, and this is a common subnet for local networks.

The issue is that your Linux server has the IP of 10.88.77.111, which is an entirely different subnet. This means it likely did not receive an address from your router properly, and because of this Windows cannot ping the Linux server.

I would remove the network bridge, check all of your settings, and try to create it again. Did you change any settings from default when creating the bridge, such as setting static addresses under the "Internet Protocol Version 4 (TCP/IPv4)" properties, for example?

Edit:

Since your Linux server is a virtual machine, the above information does not apply to your setup.

When you originally setup the virtual machine, did you change any of the network settings?

Edit #2:

Wait a second, that address you have your server set to looks very similar to the address VirtualBox assigns when the network settings are in NAT mode. Are you sure it is in bridged mode, like this for example: The VirtualBox Machine I am testing things with currently.

If it is in bridged mode, and not NAT, then set the /etc/network/interfaces file to automatically retrieve an IP address. It will likely look more like the Windows one. If the automatic address it gives you works, then configure the static IP address to be what it gave you automatically.

| improve this answer | |
  • The only thing I did differently from the last successful SSH, was changing the IP-address. Or at least, that's what I think I did differently. It's been a while, and I've been configuring maaaany things on my server. – ZstrZr May 30 '17 at 22:30
  • @ZstrZr Which IP address was changed? The one on the Ubuntu server, and is it a static IP address? – JohnDoe May 30 '17 at 22:32
  • The IP of the Ubuntu server changed, and yes, it's a static IP. I also changed the /etc/hosts file. There were two links to a link-local address, and I changed one of them to the new IP-address, which is 10.88.77.111. – ZstrZr May 30 '17 at 22:34
  • Is this Ubuntu Server or Ubuntu Desktop? If it is Ubuntu Server, please post the /etc/network/interfaces file and the /etc/hosts file. In the meanwhile, since it has been awhile since I used VirtualBox, I am going to create one and see how the network driver works again. Maybe I can recreate your issue or at least understand it better. Edit: I was able to recreate the issue and will try to find a solution soon. – JohnDoe May 30 '17 at 22:40
  • 1
    I've tried it out, and it works! I gave my Ubuntu Server an IP within the subnet of my Windows' one. They can both ping each other, AND SSH works. Thanks! – ZstrZr May 31 '17 at 1:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.