7

The Steam controller is running fine in Steam app's big picture mode, but when I load a game and try to use the controller, there's no response to in-game activity. I can use it, however, to open and navigate through the Steam menu by pressing the Steam button. (I already tried this solution, to no avail: How do I get a Steam Controller working?)

How can I get the controller to work in games?

Running: Ubuntu GNOME 17.04 x64 GNOME 3.24.1 Linux kernel 4.10.0-21-generic Steam beta client (built May 26, 2017)

6

Your issue may be resolved, but I have the exact same issue. After many research, I found in this thread (How do I get a Steam Controller working?) that you must have access to /dev/uinput. I just executed sudo chmod 666 /dev/uinput before launching the game and the Steam Controller worked wonderfully in game!

Hope this helps!

  • This worked for me. Thanks a tone. I don't even have a Steam Controller. I have a Logitech Rumble Pad 2. And I'm on Linux Mint 19. I did install steam-devices, but from what I could tell it made no difference. – FragmentalStew Oct 12 '18 at 6:08
4

The quick answer:

sudo apt install steam-devices

The Long answer:

I haven't used the steam controller for half a year, and i just tried to see if it was working with Ubuntu 17.10 and

"No Controller Detected" as well as no "add Steam Controller" Option in BPMode.

All while 2 things were noticeable: 1/ it worked while plugged in (although still undetected!) 2/ In wireless mode it is totally unresponsive, except that it lights on and off when restarting the computer

So I knew the controller and dongle were basically functional.

This command should make it work:

sudo apt install steam-devices

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.