1

I'm attempting to install several dev packages, but I keep into running into roadblocks, and this one is the most recent:

khishman@khishman-desktop:~/dev/powertab/build$ sudo aptitude install  qtbase5-dev  libboost-date-time-dev libboost-filesystem-dev libboost-iostreams-dev
The following NEW packages will be installed:
  libboost-date-time-dev libboost-date-time1.58-dev{ab} libboost-filesystem-dev libboost-filesystem1.58-dev{ab} libboost-iostreams-dev libboost-iostreams1.58-dev{ab} libboost-system1.58-dev{ab} libqt5concurrent5{a} 
  libqt5opengl5-dev{ab} qt5-qmake{a} qtbase5-dev{b} qtbase5-dev-tools{a} 
0 packages upgraded, 12 newly installed, 0 to remove and 0 not upgraded.
Need to get 3,362 kB of archives. After unpacking 23.3 MB will be used.
The following packages have unmet dependencies:
 libqt5opengl5-dev : Depends: libqt5opengl5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
 libboost-date-time1.58-dev : Depends: libboost-date-time1.58.0 (= 1.58.0+dfsg-5ubuntu3) but 1.58.0+dfsg-5ubuntu3.1 is installed.
 libboost-filesystem1.58-dev : Depends: libboost-filesystem1.58.0 (= 1.58.0+dfsg-5ubuntu3) but 1.58.0+dfsg-5ubuntu3.1 is installed.
 libboost-iostreams1.58-dev : Depends: libboost-iostreams1.58.0 (= 1.58.0+dfsg-5ubuntu3) but 1.58.0+dfsg-5ubuntu3.1 is installed.
 qtbase5-dev : Depends: libqt5core5a (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5dbus5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5gui5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5network5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5printsupport5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5sql5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5test5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5widgets5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5xml5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
 libboost-system1.58-dev : Depends: libboost-system1.58.0 (= 1.58.0+dfsg-5ubuntu3) but 1.58.0+dfsg-5ubuntu3.1 is installed.
The following actions will resolve these dependencies:

      Keep the following packages at their current version:              
1)      libboost-date-time-dev [Not Installed]                           
2)      libboost-date-time1.58-dev [Not Installed]                       
3)      libboost-filesystem-dev [Not Installed]                          
4)      libboost-filesystem1.58-dev [Not Installed]                      
5)      libboost-iostreams-dev [Not Installed]                           
6)      libboost-iostreams1.58-dev [Not Installed]                       
7)      libboost-system1.58-dev [Not Installed]                          
8)      libqt5opengl5-dev [Not Installed]                                
9)      qtbase5-dev [Not Installed]                                      

      Leave the following dependencies unresolved:                       
10)     qtbase5-dev recommends libqt5opengl5-dev (= 5.5.1+dfsg-16ubuntu7)


Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.

It seems like the packages are not agreeing on the minor version, for example

Depends: libqt5opengl5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed

seems to be a conflict on between 16ubuntu7 and 16ubuntu7.2 whereas

Depends: libboost-iostreams1.58.0 (= 1.58.0+dfsg-5ubuntu3) but 1.58.0+dfsg-5ubuntu3.1 is installed.

Seems to be a conflict between 5ubuntu3 and 5ubuntu3.1

If you haven't noticed I'm using aptitude and not apt-get. The switch was an attempt to get past a similar hurdle (the "...but it is not going to be installed", "you have held broken packages" hurdle), I tried sudo apt-get autoremove and sudo apt-get install -f just in case. I've also made sure to remove all the unofficial ppas

khishman@khishman-desktop:/etc/apt$ find ./ -name *.list -exec grep -E "^[\s]*deb" {} \;
deb http://ca.archive.ubuntu.com/ubuntu/ xenial main
deb http://ca.archive.ubuntu.com/ubuntu/ xenial universe
deb http://security.ubuntu.com/ubuntu xenial-security main
deb http://security.ubuntu.com/ubuntu xenial-security universe

But with no luck.

Any help will be appreciated.

  • 1
    v5.5.1+dfsg-16ubuntu7.2 is available in the xenial-updates repository but not in xenial. enable that repo and run sudo aptitude update and retry your install command. (should work with the libboost package as well.) – quixotic May 30 '17 at 6:29
  • @quixotic the problem is I have a the 7.2 version and the dependencies were on a lower level version :/ I did add the us xenial-updates archive but I'm not sure if it made a difference, I might have simply not added right because it ended up fetching everything from the ca archives – qwertyzw May 30 '17 at 23:44
0

I ended up rejecting aptitude's first solution, and the second solution turned out to be downgrading most of the dependencies to an earlier version (from 16ubunt7.2 down to 16ubuntu7 and 5ubuntu3.1 down to 5ubuntu3). I'm not sure if this was the right thing to do, but I did achieve my goal.

khishman@khishman-desktop:/etc/apt$ sudo aptitude install  qtbase5-dev libboost-dev libboost-date-time-dev libboost-filesystem-dev libboost-iostreams-dev
libboost-dev is already installed at the requested version (1.58.0.1ubuntu1)
libboost-dev is already installed at the requested version (1.58.0.1ubuntu1)
The following NEW packages will be installed:
  libboost-date-time-dev libboost-date-time1.58-dev{ab} libboost-filesystem-dev libboost-filesystem1.58-dev{ab} libboost-iostreams-dev libboost-iostreams1.58-dev{ab} libboost-regex1.58-dev{ab} libboost-serialization1.58-dev{ab} 
  libboost-serialization1.58.0{a} libboost-system1.58-dev{ab} libqt5concurrent5{a} libqt5opengl5-dev{ab} qt5-qmake{a} qtbase5-dev{b} qtbase5-dev-tools{a} 
0 packages upgraded, 15 newly installed, 0 to remove and 14 not upgraded.
Need to get 3,944 kB of archives. After unpacking 29.4 MB will be used.
The following packages have unmet dependencies:
 libqt5opengl5-dev : Depends: libqt5opengl5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
 libboost-date-time1.58-dev : Depends: libboost1.58-dev (= 1.58.0+dfsg-5ubuntu3.1) but 1.58.0+dfsg-5ubuntu3 is installed.
 libboost-regex1.58-dev : Depends: libboost1.58-dev (= 1.58.0+dfsg-5ubuntu3.1) but 1.58.0+dfsg-5ubuntu3 is installed.
                          Depends: libboost-regex1.58.0 (= 1.58.0+dfsg-5ubuntu3.1) but it is not going to be installed.
 libboost-serialization1.58-dev : Depends: libboost1.58-dev (= 1.58.0+dfsg-5ubuntu3.1) but 1.58.0+dfsg-5ubuntu3 is installed.
 libboost-filesystem1.58-dev : Depends: libboost1.58-dev (= 1.58.0+dfsg-5ubuntu3.1) but 1.58.0+dfsg-5ubuntu3 is installed.
 libboost-iostreams1.58-dev : Depends: libboost1.58-dev (= 1.58.0+dfsg-5ubuntu3.1) but 1.58.0+dfsg-5ubuntu3 is installed.
 qtbase5-dev : Depends: libqt5core5a (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5dbus5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5gui5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5network5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5printsupport5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5sql5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5test5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5widgets5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
               Depends: libqt5xml5 (= 5.5.1+dfsg-16ubuntu7) but 5.5.1+dfsg-16ubuntu7.2 is installed.
 libboost-system1.58-dev : Depends: libboost1.58-dev (= 1.58.0+dfsg-5ubuntu3.1) but 1.58.0+dfsg-5ubuntu3 is installed.
The following actions will resolve these dependencies:

      Keep the following packages at their current version:              
1)      libboost-date-time-dev [Not Installed]                           
2)      libboost-date-time1.58-dev [Not Installed]                       
3)      libboost-filesystem-dev [Not Installed]                          
4)      libboost-filesystem1.58-dev [Not Installed]                      
5)      libboost-iostreams-dev [Not Installed]                           
6)      libboost-iostreams1.58-dev [Not Installed]                       
7)      libboost-regex1.58-dev [Not Installed]                           
8)      libboost-serialization1.58-dev [Not Installed]                   
9)      libboost-system1.58-dev [Not Installed]                          
10)     libqt5opengl5-dev [Not Installed]                                
11)     qtbase5-dev [Not Installed]                                      

      Leave the following dependencies unresolved:                       
12)     qtbase5-dev recommends libqt5opengl5-dev (= 5.5.1+dfsg-16ubuntu7)


Accept this solution? [Y/n/q/?] n   
The following actions will resolve these dependencies:

      Install the following packages:                                                                 
1)      libboost-date-time1.58-dev [1.58.0+dfsg-5ubuntu3 (xenial)]                                    
2)      libboost-filesystem1.58-dev [1.58.0+dfsg-5ubuntu3 (xenial)]                                   
3)      libboost-iostreams1.58-dev [1.58.0+dfsg-5ubuntu3 (xenial)]                                    
4)      libboost-regex1.58-dev [1.58.0+dfsg-5ubuntu3 (xenial)]                                        
5)      libboost-regex1.58.0 [1.58.0+dfsg-5ubuntu3 (xenial)]                                          
6)      libboost-serialization1.58-dev [1.58.0+dfsg-5ubuntu3 (xenial)]                                
7)      libboost-serialization1.58.0 [1.58.0+dfsg-5ubuntu3 (xenial)]                                  
8)      libboost-system1.58-dev [1.58.0+dfsg-5ubuntu3 (xenial)]                                       

      Downgrade the following packages:                                                               
9)      libboost-date-time1.58.0 [1.58.0+dfsg-5ubuntu3.1 (now) -> 1.58.0+dfsg-5ubuntu3 (xenial)]      
10)     libboost-filesystem1.58.0 [1.58.0+dfsg-5ubuntu3.1 (now) -> 1.58.0+dfsg-5ubuntu3 (xenial)]     
11)     libboost-filesystem1.58.0:i386 [1.58.0+dfsg-5ubuntu3.1 (now) -> 1.58.0+dfsg-5ubuntu3 (xenial)]
12)     libboost-iostreams1.58.0 [1.58.0+dfsg-5ubuntu3.1 (now) -> 1.58.0+dfsg-5ubuntu3 (xenial)]      
13)     libboost-system1.58.0 [1.58.0+dfsg-5ubuntu3.1 (now) -> 1.58.0+dfsg-5ubuntu3 (xenial)]         
14)     libboost-system1.58.0:i386 [1.58.0+dfsg-5ubuntu3.1 (now) -> 1.58.0+dfsg-5ubuntu3 (xenial)]    
15)     libqt5core5a [5.5.1+dfsg-16ubuntu7.2 (now) -> 5.5.1+dfsg-16ubuntu7 (xenial)]                  
16)     libqt5dbus5 [5.5.1+dfsg-16ubuntu7.2 (now) -> 5.5.1+dfsg-16ubuntu7 (xenial)]                   
17)     libqt5gui5 [5.5.1+dfsg-16ubuntu7.2 (now) -> 5.5.1+dfsg-16ubuntu7 (xenial)]                    
18)     libqt5network5 [5.5.1+dfsg-16ubuntu7.2 (now) -> 5.5.1+dfsg-16ubuntu7 (xenial)]                
19)     libqt5opengl5 [5.5.1+dfsg-16ubuntu7.2 (now) -> 5.5.1+dfsg-16ubuntu7 (xenial)]                 
20)     libqt5printsupport5 [5.5.1+dfsg-16ubuntu7.2 (now) -> 5.5.1+dfsg-16ubuntu7 (xenial)]           
21)     libqt5sql5 [5.5.1+dfsg-16ubuntu7.2 (now) -> 5.5.1+dfsg-16ubuntu7 (xenial)]                    
22)     libqt5test5 [5.5.1+dfsg-16ubuntu7.2 (now) -> 5.5.1+dfsg-16ubuntu7 (xenial)]                   
23)     libqt5widgets5 [5.5.1+dfsg-16ubuntu7.2 (now) -> 5.5.1+dfsg-16ubuntu7 (xenial)]                
24)     libqt5xml5 [5.5.1+dfsg-16ubuntu7.2 (now) -> 5.5.1+dfsg-16ubuntu7 (xenial)]                    



Accept this solution? [Y/n/q/?] Y

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.