1

Earlier this evening my system's graphics hung, all I could see was a green screen. I reset and could not get to a login GUI and was presented with a black screen, however Ctrl-Alt-F* keys opened up new terminal sessions, so I tried reinstalling the NVIDIA drivers that I had. No joy.

Before this issue, I had 3 drivers installed:

  1. nvidiafb
  2. nouveau
  3. nvidia_304

However, 0 of them were active. By purging the NVIDIA drivers, I could get back to nouveau - however this is locked to a resolution of 640x480 on one monitor and there is no xorg.conf file to be found.

It seems that the NVIDIA drivers do not work on my system, as the graphics are completely gone, however up until now the system has managed to work with 3 drivers and 0 of them being active.

Are there any troubleshooting steps that I could take to increase the resolution and get both of the displays operating again? All answers that I could find resulted in ensuring that nouveau wasn't blacklisted and removing the xorg.conf file.

Ubuntu OS Version: 16.04

Edit: I should probably add that the version of nouveau that I have installed is listed as being compatible with arm64 architectures like so. I'm not sure if this is standard for the driver but I am currently running a 64bit Intel i5-3570k processor, which seems like it may be a potential root of the problem. Hopefully this helps.

Edit 2: Graphics card: NVIDIA GTX 670.

  • Nvidia drivers are often hardware specific. Please edit and add hardware specifications, namely the Nvidia graphics card you have. Without this information nobody can give a proper answer. – user692175 May 30 '17 at 9:27
  • Added the graphics card to the question text. – NimbleNavigator May 30 '17 at 11:09
  • A wrong driver unsurprisingly. The ancient 304 doesn't support the GTX670. I can give a more complete answer now, not just a comment. – user692175 May 30 '17 at 11:15
  • Thank you, I retried installing the 304 driver before reading this comment but have now purged it in preparation for your answer. – NimbleNavigator May 30 '17 at 11:18
  • amd64, not arm. And yes, amd64 is for all 64-bit CPUs. – user692175 May 30 '17 at 11:42
0

The nVidia GTX670 (reference board) requires proprietary drivers v. 367 or newer. The nvidia-304 you have/had installed doesn't support this card as is meant for legacy hardware only.

Purge and install a correct driver:

sudo apt purge nvidia*

(don't forget the "*")

Now open Settings -> Software Properties (or Software & Updates) -> Additional drivers -or- search "Additional drivers" in the dash.

Select the recommended nvidia driver (must be v. 367 or higher, the picture is for illustration only) and Apply Changes . Reboot.

enter image description here

Considering the drivers offered in 16.04 aren't working as desired, a new repository (PPA) should be added

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update  

sudo apt purge nvidia*
sudo apt install nvidia-378  

-or-

sudo apt install nvidia-381  

Fully update: sudo apt full-upgrade

  • Following these steps, to install the NVIDIA 375 driver, I get visual glitches on screen and cannot start tty sessions. – NimbleNavigator May 30 '17 at 11:32
  • Better 367 or 378 or 381 (not mentioned at Geforce.com but works). 375 have or had a few bugs. – user692175 May 30 '17 at 11:40
  • What versions are shown 16.04? I'm running 17.04 so can't check what should be offered in yours. – user692175 May 30 '17 at 11:44
  • These are the drivers that are shown. Running sudo apt-get install nvidia-367 simply reinstalled the nvidia-375 driver again. – NimbleNavigator May 30 '17 at 11:49
  • @NimbleNavigator Updated! – user692175 May 30 '17 at 11:58
-1

Try this:

sudo apt-get install x11-xserver-utils

( That won't hurt if you already have it. )

Then:

xrandr

A + sign should appear beside the ideal rez. A * should appear beside the current setting. To change:

xrandr -s WxH

where W and H are the numbers from the rez you choose to use, presumably the one with the + by it. Won't work for all systems, but won't hurt to try it.

  • Unfortunately that didn't work. I already had that package installed and xrandr gave this result. – NimbleNavigator May 29 '17 at 22:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.