0

I have python 2.7 installed, and want to upgrade to python 3. I have run sudo apt-get update && sudo apt-get upgrade and then sudo apt-get install python 3.33. However, I get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libghc-abstract-par-dev-0.3.3-3512c:i386' for regex '3.3.3'
Note, selecting 'libgolang-gopkg-inconshreveable-log15.v2-1-e13295a893e12a6ed7d17ea32997530d737393ec' for regex '3.3.3'
Note, selecting 'libghc-http-streams-dev-0.8.3.3-31b05' for regex '3.3.3'
Note, selecting 'libghc-http-streams-prof-0.8.3.3-31b05' for regex '3.3.3'
Note, selecting 'liblttoolbox3-3.3-0' for regex '3.3.3'
Note, selecting 'liblttoolbox3-3.3-0v5' for regex '3.3.3'
Note, selecting 'libghc-abstract-par-prof-0.3.3-3512c:i386' for regex '3.3.3'
Note, selecting 'bve-train-br-class-323-3dcab' for regex '3.3.3'
Note, selecting 'libgolang-github-olekukonko-tablewriter1-47572dd4d99fd6673f303c8825b067cd96b5171b:i386' for regex '3.3.3'
Note, selecting 'libghc-hspec-dev-2.2.3-393ec' for regex '3.3.3'
Note, selecting 'libghc-hspec-prof-2.2.3-393ec' for regex '3.3.3'
Note, selecting 'libgolang-gopkg-inconshreveable-log15.v2-1' instead of 'libgolang-gopkg-inconshreveable-log15.v2-1-e13295a893e12a6ed7d17ea32997530d737393ec'
Note, selecting 'libgolang-github-olekukonko-tablewriter1:i386' instead of 'libgolang-github-olekukonko-tablewriter1-47572dd4d99fd6673f303c8825b067cd96b5171b:i386'
Note, selecting 'libghc-http-streams-dev' instead of 'libghc-http-streams-dev-0.8.3.3-31b05'
Note, selecting 'libghc-http-streams-prof' instead of 'libghc-http-streams-prof-0.8.3.3-31b05'
Note, selecting 'libghc-hspec-dev' instead of 'libghc-hspec-dev-2.2.3-393ec'
Note, selecting 'libghc-hspec-prof' instead of 'libghc-hspec-prof-2.2.3-393ec'
Note, selecting 'libghc-abstract-par-dev:i386' instead of 'libghc-abstract-par-dev-0.3.3-3512c:i386'
Note, selecting 'libghc-abstract-par-prof:i386' instead of 'libghc-abstract-par-prof-0.3.3-3512c:i386'
python is already the newest version (2.7.11-2).
python set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libghc-abstract-par-dev:i386 : Depends: libghc-base-dev-4.8.2.0-a3ce8:i386
                                Depends: libghc-deepseq-dev-1.4.1.1-d8d3c:i386
 libghc-abstract-par-prof:i386 : Depends: libghc-base-prof-4.8.2.0-a3ce8:i386
                                 Depends: libghc-deepseq-prof-1.4.1.1-d8d3c:i386
 libghc-hspec-dev : Depends: libghc-hunit-dev-1.3.1.1-9ae4c
                    Depends: libghc-quickcheck-dev-2.8.2-c0e1f
                    Depends: libghc-base-dev-4.8.2.0-0d6d1
                    Depends: libghc-hspec-core-dev-2.2.3-f8063
                    Depends: libghc-hspec-expectations-dev-0.7.2-3fed3
                    Depends: libghc-transformers-dev-0.4.2.0-81450
 libghc-hspec-prof : Depends: libghc-hunit-prof-1.3.1.1-9ae4c
                     Depends: libghc-quickcheck-prof-2.8.2-c0e1f
                     Depends: libghc-base-prof-4.8.2.0-0d6d1
                     Depends: libghc-hspec-core-prof-2.2.3-f8063
                     Depends: libghc-hspec-expectations-prof-0.7.2-3fed3
                     Depends: libghc-transformers-prof-0.4.2.0-81450
 libghc-http-streams-dev : Depends: libghc-hsopenssl-dev-0.11.1.1-91ed0
                           Depends: libghc-aeson-dev-0.11.2.1-f3d34
                           Depends: libghc-attoparsec-dev-0.13.0.2-bf2aa
                           Depends: libghc-base-dev-4.8.2.0-0d6d1
                           Depends: libghc-base64-bytestring-dev-1.0.0.1-a812c
                           Depends: libghc-blaze-builder-dev-0.4.0.2-efcd4
                           Depends: libghc-bytestring-dev-0.10.6.0-9a873
                           Depends: libghc-case-insensitive-dev-1.2.0.7-78ae3
                           Depends: libghc-directory-dev-1.2.2.0-660a7
                           Depends: libghc-http-common-dev-0.8.2.0-e5706
                           Depends: libghc-io-streams-dev-1.3.5.0-64cb4
                           Depends: libghc-mtl-dev-2.2.1-3af90
                           Depends: libghc-network-dev-2.6.3.1-1a316
                           Depends: libghc-network-uri-dev-2.6.1.0-247a0
                           Depends: libghc-openssl-streams-dev-1.2.1.0-c6b18
                           Depends: libghc-text-dev-1.2.2.1-f5b16
                           Depends: libghc-transformers-dev-0.4.2.0-81450
                           Depends: libghc-unordered-containers-dev-0.2.7.1-da668
 libghc-http-streams-prof : Depends: libghc-hsopenssl-prof-0.11.1.1-91ed0
                            Depends: libghc-aeson-prof-0.11.2.1-f3d34
                            Depends: libghc-attoparsec-prof-0.13.0.2-bf2aa
                            Depends: libghc-base-prof-4.8.2.0-0d6d1
                            Depends: libghc-base64-bytestring-prof-1.0.0.1-a812c
                            Depends: libghc-blaze-builder-prof-0.4.0.2-efcd4
                            Depends: libghc-bytestring-prof-0.10.6.0-9a873
                            Depends: libghc-case-insensitive-prof-1.2.0.7-78ae3
                            Depends: libghc-directory-prof-1.2.2.0-660a7
                            Depends: libghc-http-common-prof-0.8.2.0-e5706
                            Depends: libghc-io-streams-prof-1.3.5.0-64cb4
                            Depends: libghc-mtl-prof-2.2.1-3af90
                            Depends: libghc-network-prof-2.6.3.1-1a316
                            Depends: libghc-network-uri-prof-2.6.1.0-247a0
                            Depends: libghc-openssl-streams-prof-1.2.1.0-c6b18
                            Depends: libghc-text-prof-1.2.2.1-f5b16
                            Depends: libghc-transformers-prof-0.4.2.0-81450
                            Depends: libghc-unordered-containers-prof-0.2.7.1-da668
 libgolang-github-olekukonko-tablewriter1:i386 : Depends: libgolang-1.6-std1-c60847a6bb7f126f07e6a74f03d02623085c60a7:i386
E: Unable to correct problems, you have held broken packages.

Another issue that isn't clear to me is that in the middle of the message it says "python is already the newest version (2.7.11-2).". I have tried to understand what libgolang is in order to install it manually, but could not find anything relevant.

Thanks,

3
  • What version of Ubuntu is this? Please check if python 3 is there: python3 -V – George Udosen May 29 '17 at 15:51
  • It's Ubuntu 16.10. Strangely python3 -V returns Python 3.5.2+, but python --version returns Python 2.7.12+. – user1767774 May 29 '17 at 16:05
  • Its not strange you have two versions of python onboard: python3 -V --> version 3, and python -V --> version 2 – George Udosen May 29 '17 at 16:08
3

Please don't update as you already have python 3 pre-installed in your Ubuntu. To check do:

Python 3: python3 -V, Python 2: python -V. These are the default python installs that come with your Ubuntu installation.

Please enjoy their presence.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.