2

A system got a fresh install of Ubuntu 16.04.2 LTS. The connected ELO touch display works fine in landscape mode. Having the display being installed in clockwise rotated portrait format, led to switching the display mode to portrait via the System Settings > Displays dialog, similar to this resolution change description. The portrait display setting works fine, but the touch screen input does not rotate appropriately. Installation and start up of xinput-calibrator seems to work, as no error is given, but all touch input events result in (then calibrated) upper right hand touch events on the portrait format display, irrespectively of the actual touch position on the screen.

The console output of xinput_calibrator is:

$ sudo xinput_calibrator 
    Setting calibration data: 0, 4095, 0, 4095
Calibrating EVDEV driver for "Elo TouchSystems, Inc. Elo TouchSystems 2700 IntelliTouch(r) USB Touchmonitor Interface" id=10
    current calibration values (from XInput): min_x=0, max_x=4095 and min_y=0, max_y=4095

Doing dynamic recalibration:
    Swapping X and Y axis...
    Setting calibration data: 2604, 2599, 1620, 1635
    --> Making the calibration permanent <--
  copy the snippet below into '/etc/X11/xorg.conf.d/99-calibration.conf' (/usr/share/X11/xorg.conf.d/ in some distro's)
Section "InputClass"
    Identifier  "calibration"
    MatchProduct    "Elo TouchSystems, Inc. Elo TouchSystems 2700 IntelliTouch(r) USB Touchmonitor Interface"
    Option  "Calibration"   "2604 2599 1620 1635"
    Option  "SwapAxes"  "1"
EndSection

As calibration does not work, no permanent configurations were made to the suggested 99-calibration.conf. I did not find a similar problem were all touch events were calibrated to a single corner of the screen. I tried then calibration with the display in landscape mode, which works fine. Any hints?

2

The answer here worked for me on Debian, so it may work for you too.

I've copied it below in case the link breaks.

by NeillyThere » Mon Sep 23, 2013 11:39 am
The X11 Y-axis problem - a simple solution!

If you've got the problem with the Y-axis being inverted (it goes up as you move down, or vice-versa), a simple solution is as follows:

Using your preferred text editor with sudo (or root access) edit usr/share/X11/xorg.conf.d/10-evdev.conf It contains configuration details for evdev (that which handles the touchscreen). You'll note that the file is divided into several (5) sections following the comment block at the top. Each section beginning with the word Section and ending with the word EndSection (yes it is obvious but ...). One of those sections, most probably the last one will be:

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection

before that EndSection insert a new line:

Option "InvertY" "true"

So the section now reads:

Section "InputClass"
        Identifier "evdev touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "InvertY" "true"
EndSection

Save the file and try starting X11 again.
I've successfully tested this on both the 2013-07-26 and 2013-09-10 versions of Raspbian.

So hopefully problem solved.

This worked for me after a reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.