I have install Ubuntu 11.10 64bit on my Hp Dv6-3150el. My Notebook has two graphics cards:

lspci | grep VGA
00:02.0 VGA compatible controller: 
 Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: 
 ATI Technologies Inc Madison [AMD Radeon HD 5000M Series]

I tried to install the proprietary graphics drivers ''fglrx'' available in "Additional Drivers", which does not give me 3D graphics acceleration (and I can't install those post-release).
Then I can try to download and install from the website (I tried the version that Catalyst 11.8 11.12).
The installation goes perfectly (I followed this guide and others), except that when I configure Xorg.conf file:

sudo aticonfig --initial
PowerXpress error: Cannot stat '/usr/lib64/fglrx': No such file or directory
Failed to initialize libglx for discrete GPU

What I did was copy the /usr/lib/fglrx folder to /usr/lib64/fglrx:

sudo cp /usr/lib/fglrx /usr/lib64/fglrx

After restarting the XServer I was able to open AMD Control Panel and choose between dGPU and iGPU.


I think you want to make a symbolic link between /urs/lib64 and /usr/lib so it would be

ln -s /usr/lib /usr/lib64

But I'm not sure that will solve your issues. After running aticonfig and restarting my computer, I got a black screen.


I've used this forum post with success: http://ubuntuforums.org/showthread.php?t=1930450

my lspci displays:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler [AMD Radeon HD 6600M Series] (rev ff)

however there is a difference between Radeon 5xxx and Radeon 6xxx devices.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.