I am somewhat new to Linux and even more so to PowerPC based Linux.

I downloaded Lubuntu 14.04.5 for PowerPC and created a bootable DVD, which worked just fine on my iMac G5, minus the annoying nvidia issues. When I took it to my G3 B&W tower, with a Sonnet Crescendo ZIF 1ghz G4 upgrade, it booted fairly quickly but froze on the splash screen. Hoping it was just a video hang, I let it sit for an hour and came back but alas it is frozen.

Is there an issue with Sonnet processor upgrades or could it be something else like my Radeon 9200 PCI video card or possibly my DVD drive?

My CPU specs are:

PowerPC G3 B&W (tower) Sonnet Encore 1ghz PowerPC G4 ZIF 60mhz system bus 576mb RAM (yes, it's a weird number lol) PCI Radeon 9200 128mb VRAM Pioneer DVD-RW Iomega ZIP 100 120gb + 16gb IDE HDD Mac OS 9.2.2/10.4.11

Outside installing via terminal (with google) and point and click, I am virtually clueless when it comes to Linux.

Has anyone here installed on a machine like mine or did I mod it too much and create my typical one-of-a-kind "Frankenmac" machines and cut myself out of the loop?

Considering the crap that everyone picks up at Walmart nowadays, I would love to get that beast back online as it's not like the machine isn't able to keep up with the newer hardware. My only hurdle is java and flash releases and it seems that iCab for OS X has been pretty much abandoned on PowerPC. After putting Ubuntu on a few "older" PCs and testing it side by side with brand new laptops running Win 7 and 8.1, I'm completely smitten with Linux.


Ubuntu MATE 16.04 worked well on an iBookG4, this might be worth trying on your machine. I found that even with windows PCs its worth trying different versions of a distro to find one that works. If you get lucky, that is easier than hacking about to make something work.

A bit of google-searching finds some posts from the early 2000's reporting that Linux kernel cannot run with the Sonnet upgrade cards.


the advice refers to very old versions of linux, so its not clear what you might be able to try on your machine.

  • Ok so I made a new install DVD and it loads and seems stable running live mode. The new problem I have is that when I run the installer, I cannot get past the stage where I would normally format a hard drive. It hangs there indefinetly. – frankenmacg4 May 31 '17 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.