0

Last night, I shut down my computer (running Ubuntu 16.04) normally and went to bed. This morning, I tried to boot Ubuntu and I encountered this: Image: Ubuntu boot stuck.

Ubuntu won't boot and recovery mode encounters a kernel panic. It says /sbin/init: No such a file or directory and I tried this solution (that I found on multiples sites). It says init is already installed. Also, I tried boot-repair and after that I am facing the same problem as before. It seems files are OK, software is up-to-date. Please help!

Edit: I'm trying to upload a picture to show what the kernel panic looks like but I can't. It says there is a problem with Imgur

  • What happens if you try and boot a prior kernel from the GRUB menu? – heynnema May 28 '17 at 20:54
  • @heynnema it goes directly to kernel panic – Arturo Reyes Jr. May 29 '17 at 6:33
  • See my partial answer... we'll go from there. – heynnema May 29 '17 at 13:15
0

Partial answer... work in progress...

Since you can't get to recovery mode, lets try and check your file system using external media.

  • boot to a Ubuntu Live DVD/USB
  • start gparted and determine which /dev/sdaX is your Ubuntu EXT4 partition
  • quit gparted
  • open a terminal window
  • type sudo fsck -f /dev/sdaX # replacing X with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.