I am running ubuntu 16.04 live usb persistent.

when I type this command - sudo update-grub

I get this error- /usr/sbin/grub-probe: error: failed to get canonical path of aufs'.

I found a work around buy applying these commands and the error no longer occur.-

sudo apt-get update;
sudo apt-get install grub

(it actually installs grub 0.9)

But I need to edit grub.cfg and in it's not present in grub(0.9). It's in grub(2.0 latest) instead.

THEN If I install grub(2.0), I suffer with this problem again - /usr/sbin/grub-probe: error: failed to get canonical path of aufs'.

WHAT should I do next to resolve this?

My previous question and how I get here-

How do I add a kernel boot parameter on live session itself?

Make boot parameters permanent on live session itself?

Ubuntu is not booting up with desired parameter?

missing grub.cfg file instead have menu.lst on ubuntu 16.04

EDIT- same error while using 'grub customizer'-

enter image description here

EDIT - Creating boot summary info through boot-repair:- enter image description here



  • Why don't you let your system pick the right grub, and the same configuration can also be set in the earlier version. – George Udosen May 28 '17 at 16:53
  • i just want to add "pci=nomsi" boot parameter permanently. I am not being able to do it in anyway. – Jason May 28 '17 at 16:56
  • Does grub 0.9 not achieve this same goal, I believe its equivalent file is grub.conf check in the /boot/grub folder the names are just different but they both do the same thing. I saw you earlier using a grub customizer app which led to metadata errors I hope you have not upset your system. Updating grub [permanently] is done in the ways already offered you. I believe one of the solutions worked and that should suffice... – George Udosen May 28 '17 at 17:06
  • I am able to sucessfully add parameters in grub(0.9) and "nano" and sudo update-grub too. But it never boots with that parameters and effects doesnt take place. – Jason May 28 '17 at 17:10
  • sir, also can you make sense of this - link this can solve the main error i am getting which is - /usr/sbin/grub-probe: error: failed to get canonical path of aufs' – Jason May 28 '17 at 17:12

Some comments, observations, and questions:

  • GRUB 0.9 is also known as GRUB Legacy. This is an old version of GRUB that's been more-or-less completely abandoned by now. Ubuntu uses GRUB 2 by default these days. AFAIK, Ubuntu's version of GRUB Legacy is BIOS-only, which may be 100% useless to you -- but this leads to the next point....
  • I've skimmed all the questions you've posted, and I don't see mention of the single most critical issue: Are you booting in BIOS/CSM/legacy mode or in EFI/UEFI mode? You can identify the current boot mode by looking for a directory called /sys/firmware/efi. If it's present, you've booted in EFI mode; if it's absent, you've booted in BIOS mode. If you're using an emergency disk, though, its boot mode might not match that of your regular installation. This can be identified by examining the partition table, MBR contents, and other diagnostic locations, which brings me to the next point....
  • Please run the Boot Repair utility and select the "Create BootInfo Summary" option. (DO NOT click "Recommended Repair," at least not yet!) When asked whether to upload the report, click "Yes," and then post the URL provided here. This will give us more details about your configuration, which is required to base an answer on more than guesswork.
  • The error message you reported sounded familiar, and I quickly tracked down this question. The computer in that case used an NVMe disk, and it looks like GRUB's scripts don't do a good job of handling such disks. The poster of that question finally got it working, but from his comments, it's not 100% clear what he did. In any event, it's conceivable (but far from certain) that the cause and solution for you might be similar.

Overall, I'd say that you MUST post a BootInfo summary if you expect to get help. Without that, the best anybody can do is take a wild guess at a solution. That said, there's a chance that the answer to the question I referred to above may be helpful.

You might also consider posting on the Ubuntu forums; that venue is better for extensive back-and-forth interactions; this site works better for solving straightforward problems that don't require answering an extensive set of follow-up questions from those trying to help.

  • Boot-repair doest open from launcher and it only opens through these command - sudo apt-get install -y boot-repair && boot-repair . I followed your steps and it doest create any links. I even once tried it on freshly installed ubuntu live usb. – Jason May 29 '17 at 16:16
  • I'm pretty sure there's a way to save the results to a file called RESULTS.txt. Try doing that and then post the file to a pastebin site, and post the URL to your document here. – Rod Smith May 29 '17 at 16:28
  • I added the file. – Jason May 30 '17 at 10:37
  • Try the recommended repair from Boot Repair. If that doesn't work, post the URL that it provides, or re-run it to get a new BootInfo summary and post the URL to it. – Rod Smith May 30 '17 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.